Reply
Regular Contributor
JasonWard
Posts: 35
0

Re: Failed to connect to the engine

Might be worth mentioning them here.
Frequent Contributor
A_Pickle
Posts: 15
0

Re: Failed to connect to the engine

http://en.wikipedia.org/wiki/Hamachi#See_also

 

 There's a good list there.

Frequent Contributor
A_Pickle
Posts: 15
0

Re: Failed to connect to the engine

Um, once again...

 

...this has not been solvedWhy haven't we seen any official response from LogMeIn for what appears to be a pretty widespread problem with Hamachi2?  And why is this thread not on the front page?

 

Frequent Contributor
A_Pickle
Posts: 15
0

Re: Failed to connect to the engine

Awesome!  It's great to see LogMeIn SO concerned about this widespread problem with Hamachi2 that they haven't even had time to officially comment on this thread.  Oh, wait, I forgot:  Most of us are probably using free Hamachi2, which absolves LogMeIn of any responsibility in maintaining this app and, you know, making it work reliably.

 

That's right, LogMeIn.  Ignore the problem, that'll make it go away.  Rather, that'll make users ditch your lousy support (rather, entire lack thereof) by switching to one of MANY alternative zero-configuration VPN clients available online. Then there won't be any users complaining about the "Failed to connect to the engine" problem!  What a great fix!

 

Sincerely,

-A Hamachi2 user who was interested in getting this product for his business, but having seen the "support" offered by this company to it's free users, is more and more interested in alternative solutions.

 

PS:  Although a patch to this problem would be wonderful, I am sympathetic to the difficult and competitive business of software development.  A simple comment on this thread by a LogMeIn developer, as well as removal of the "Solved!" (because this problem is not solved - nor even addressed) tagline would make me perfectly happy, as it would be indicative that you actually care about your customers.

New Contributor
Bunlue-Thailand
Posts: 2
4

Re: Failed to connect to the engine

Go to Administrative Tools-->Services-->LogMeIn Hamachi 2.0 Tunneling Engine

Press Start button or right click the service name and select Start.

 

I then can start the Hamachi2 console.

New Contributor
cebert
Posts: 1
1

Re: Failed to connect to the engine


Bunlue-Thailand wrote:

Go to Administrative Tools-->Services-->LogMeIn Hamachi 2.0 Tunneling Engine

Press Start button or right click the service name and select Start.

 

I then can start the Hamachi2 console.


 

 

 

Thanks Bunlue-Thailand!  Your solution worked for me.  Your post should have the real "solved" banner attached to it.

I don't know why the Tunneling Engine is installed but not enabled by default. The same problem happened on all my computers. Maybe some security software is preventing this.

New Contributor
Tuinslak
Posts: 1
0

Re: Failed to connect to the engine

I so far have only seen this error appear on WinXP.

 

It happens when Hamachi GUI is starting before the service has started.

 

I made a rather dirty work around, but fixed the problem on all XPs that had the issue. 

New Contributor
schreckli
Posts: 1
0

Re: Failed to connect to the engine

Bunlue-Thailand is a genius!  Hamachi2 works again for me!!!!
Contributor
Facere
Posts: 8
0

Re: Failed to connect to the engine

Having the same issue more or less frequently on different computers (commercial version), but the work around often does not work since the service status is "starting", which means I am able to right click - start it :( 
New Contributor
Overklok
Posts: 1
0

Re: Failed to connect to the engine

Indeed, hard for a VPN to run with no tunneling.

 

 Strange that the startup type is automatic, yet it doesn't run.

 

You may want to consider adding a line to your startup script to include 'net start "LogMeIn Hamachi 2.0 Tunneling Engine"'

 

you'll need to include the double quotes around the service name for windows to understand it as 1 service and not 2.

 

Thanks for the post, this clarified what I had suspected.