Reply
New Contributor
Bunlue-Thailand
Posts: 2
0

Re: Failed to connect to the engine

I think this is a bug in Hamachi2, and should be fixed by Logmein.

 

My Hamachi Tunneling Service did have startup type as "Automatic" and it started on every Windows power up.

But, for my machine, the service stop from time to time!

 

I notice that the service stop when it trying to connect to some of then "off line" or "bad connection" VPN client, (the green button blink and stop with yellow, or red). During retrying, sometime the service simply stop!

 

I can restart the service as mentioned above, but it should not happen like this. Hope that  there should release version "2.1" soon!

 

Contributor
IEMCO
Posts: 5
0

Re: Failed to connect to the engine

I have this issue on several of my Clients, however, hamachi2 starts anyway and eventually connects. I just  do not get the interface to pop-up until i manuall start hamachi2.

 

Based on this I suspect an addition of DependOnService stringwith the correct value(tcpip?,lanmanworkstation?,NetBIOS?, NetBT?) in the HKLM\SYSTEM\CurrentControlSet\Services\Hamachi2Svc key would solve the problem

Contributor
Eric-Jan
Posts: 10
0

Re: Failed to connect to the engine

When you put the start of the UI it in the Startup folder it might get started before the Hamachi2 tunnel service is up and running.

 

Put a delay in front of it. There are other more elegant sollutions. But this simple one works for me.

 

C:\Windows\System32\cmd.exe /c sleep 20 && start "" /MIN "C:\Program Files\LogMeIn Hamachi\hamachi-2-ui.exe"

 

With regards

New Contributor
Hassan 22
Posts: 1
0

Re: Failed to connect to the engine

any new solution, the previous solution solution doesn't work with me
Active Contributor
therain
Posts: 4
0

Re: Failed to connect to the engine

I wrote this little program for fixing the issue.

it set Hahachi service autostart to manual.
It start hamachi

 

Download link:
http://cid-99b22ff1d200a1db.skydrive.live.com/self.aspx/.Public/Hamachi2svc.zip

http://www.mediafire.com/file/imianncom3l/Hamachi2svc.zip

New Contributor
Zakusho
Posts: 1
0

Re: Failed to connect to the engine

i got the best solution... in case you guys haven't notice at the services where the logmein thing is... it says at properties clearly what the path to the actual executable is... and that is hamachi tunneling exe not the ui one... and also you can see a -s at it... well ta da! make a shortcut to the exe(the one with tunneling engine thing:hamachi-2.exe) and add at path a -s. this also opens hamachi for me... i mean no need to use the other shortcut well at least for me...

 

Oh i added a download also in case you guys can't make it work... oh... and notice that the path to the downloaded shortcut i put is for my computer... change it accordingly to ur path.

http://www.filefront.com/16498631/hamachi-2.exe/

or

http://www.filefront.com/user/zakusho

New Contributor
J_Davis1254
Posts: 1
0

Re: Failed to connect to the engine

You are a genius. I am on Win 7 and also worked  perfectly.

 

Thanks for taking the time to post!

New Contributor
converseme
Posts: 1
0

Re: Failed to connect to the engine

I have exactly the same problem except none solution above helped me.

 

Here some screens:

 

http://img155.imageshack.us/img155/6628/error1c.jpg

 

http://img413.imageshack.us/img413/5435/error2k.jpg

 

and when i try to start hamachi gives me the error Failed to connect to the engiene.

 

Someone have a solution?

 

Im running win7x64 btw

Active Contributor
therain
Posts: 4
0

Re: Failed to connect to the engine

conserveme:

 

Seems like the engine did not install in your system. Try the following and see if it will start hamachi.

 

Start > Run > cmd

in the comand prompt, key in the following exactly.

net start Hamachi2svc

 

If it does not work, the hamachi service process is not installed or diabled. Try using the file i posted earlier. If the service is diabled, it will enable it (to manual)

http://www.mediafire.com/?imianncom3l

 

If above still doesn't work, reinstall hamachi. Otherwise, can't help.

 

Frequent Contributor
hispanico
Posts: 10
0

Re: Failed to connect to the engine

Thank for the program that work for me... just a request: now when hamchi start a windows of hamachi appear and i must close it, while before this little window not appear and go directly in system bar..

 

Hispanico