Reply
New Contributor
vistman
Posts: 2
0

Hamachi 2 with Windows 7

[ Edited ]

OK, 1st of all I did a lot of searching before writting this post, but could not find any informations related to my problem.

 

I have installed Hamachi 2 on my Windows 7 (x64) machine, but I simply cannot access any other PCs in my VPN.

 

I thought this will help me - /logmein/board/message?board.id=11&thread.id=739, but it did not.

 

When I click on Hamachi network adapter status I always see "No Internet Access" message.

 

I have KIS 2010 installed, but firewall rules allow Hamachi to access internet, so firewall should not be the problem.

 

This machine is behind NAT, but I do not think this should have any influence on connection status, since I haveworking internet connection.

 

Does anyone have any good solutions to my problem?

 

Thanx in advance.

OK, so far since there are no answers to my post, here are my observations.
Firewall is NOT the problem, since problem persists even if firewall is off, but even if on it allows hamachi to connect on all protocols and ports.
Obviously cross-platform windows xp - windows 7 (x64  in my case) is not functioning and actually is not very well supported in Hamachi so far.
 
 OK, here is my latest update about possible solutions to my problem.
I have uninstalled hamachi clients on both OS-es and deleted them using web interface as well as I deleted vpn. Then I reinstalled both clients (BUT READ BELOW BEFORE REINSTALLING CLIENT ON WINDOWS 7) and afterward again created new vpn network and assigned both clients to that vpn network(very smart thing to do from me ;-).
 I have modified gateway on WinXP Hamachi connection as described here - /logmein/board/message?board.id=11&thread.id=73.
The next problem to resolve is issue with Windows 7 and assigning Public and Private networks. So follow these steps before reinstalling hamachi client on W7 to be able to make it a private network, because this will not affect existing networks, just newly created ones. Type "secpol.msc" in W7 Search programs and files after clicking on start button. After new window pops up go to Network Manager List Policies on the left side and click one by one item on the right side and click on each "allow user to change ..."(or something like that, you will figure it out yourself)
Now reinstall hamachi client on W7 and you will be able to make it a private network.
This procedure took me some time to figure out, but afterward I was able to see both of my computers in hamachi client as online and connected. The problem I still have is that I am able to ping my WinXP machine from W7 machine, but not the opposite. I also cannot browse any computer, but at least chat is working (not that I actually need it).
So it is obvious that there is still some issue to resolve in W7 to be able to get full functionality.
I hope this will help someone and maybe someone will find a solution and help me out.
 Addon:
I have also tried one other free remote control solution which has support for vpn (and which also has remote desktop feature with file transfer), but I get the same result as with hamachi, therefore I obviously have problem either with gateway and NAT (W7 x64 machine) or W7 is having trouble by itself in establishing proper communication. I will investigate this further by installing clean W7 x64 machine which will not be behind gateway and NAT.
OK, here are my final thoughts on W7 (x64) and Hamachi2 client - THEY DO NOT WORK TOGETHER! I have successfully installed one other free vpn solution and it works like a charm, so I uninstalled Hamachi2 completely.
 I also may have found solutions to several issues on this forum related to Kaspersky Internet Security. If you want any kind of vpn (like this one) services to work if you have KIS installed on your OS, you should open kaspersky main panel -> Settings -> Firewall -> Settings -> Networks tab -> find all vpn network adapters you have installed on your computer and make them to be trusted network. This will allow you to use any vpn service with KIS.
The most important thing I did is corrected all typos in my post ;-)
Message Edited by vistman on 10-05-2009 03:56 PM