Reply
New Contributor
JareX
Posts: 2
0

Relayed Tunnel (Blue Dots) Despite allowing Ports on both Firewall and Router

When I connect to a hamachi network, I see all users with a blue dot, it says relayed tunnel.

 

There is no error message, just the blue dots. I also noticed it takes hamachi longer time to connect, it stays on "Probing..." like 20 secs and then it connects, but with all blue dots.

 

I have Windows Xp, a D-link Router, I have NOD32 Antivirus (it has no firewall).

 

I added ports 12975, 32976, 443, 17771 to both my windows firewall and router

 

The problem persisted.

 

I went to Hamachi System>preferences>settings(advanced) and set UDP and TCP ports to 45001 and 45002, which I port forwarded on the firewall and router.

 

Still it doesn't work.

 

I have read similar problems, I tried reinstalling hamachi, changing priority of connection etc. None has worked so far...

 

 

I would be really happy if anyone can help me with this problem.

New Contributor
JareX
Posts: 2
0

Re: Relayed Tunnel (Blue Dots) Despite allowing Ports on both Firewall and Router

 

Well, I have new info abou this problem.

 

I disabled hamachi from staring up along with windows startup (msconfig)

 

This fixed the problem!!!! Now I have direct tunnel with everyone...however

 

If I click the power button to turn hamachi off, and then I press it again to turn it on, I will get relayed tunnel again. To fix this I have to reboot PC.

 

If I reboot my PC while hamachi is ON then at the start of windows hamachi will get direct tunnel

 

If I reboot my PC while hamachi is OFF then at the start of windows I have to manually turn hamachi ON, and I will get Relayed tunnel with everyone.

 

 

At least I can have direct tunnel, but I'm still having issues.

 

The other thing thats weird is that despite I turned hamachi off from the starting up programs on msconfig, it still starts with windows...

 

So if anyone knows why this happens I would be very happy.

Trusted Contributor
Posts: 209
0

Re: Relayed Tunnel (Blue Dots) Despite allowing Ports on both Firewall and Router

There are two main parts to the Hamachi application:

hamachi-2.exe and

hamachi-2-ui.exe

 

The first exe runs as a service of the operating system. It is that exe that creates/establishes/maintains all of the VPN connections (be they relayed or direct).

 

The second exe is the User Interface (or Graphical User Interface - GUI). That is the part of the Hamachi app that you see and interact with. It sounds like you stopped this exe from automatically starting.

 

These two programs "talk" to each other. When you tell the GUI to turn off, it tells the service to break all of the VPN connections. The service also writes the on or off state to a file named h2-engine.ini. When you restart your computer, the service reads that file to see if it should make the VPN connections or not.

 

I would guess (and it is a wild guess) that some anti-virus/anti-malware/firewall software is causing your relayed connection. You do not see this after a reboot because the Hamachi service starts and makes the VPN connection before the "security" software is fully loaded and functional.

New Contributor
Biscuit_taker
Posts: 1
0

Re: Relayed Tunnel (Blue Dots) Despite allowing Ports on both Firewall and Router

so how do i make them communicate again?