Reply
New Contributor
Oleg_S
Posts: 1
0

Stop Hamachi from auto-running

So, Hamachi2 seems to like auto-running at startup, and i don't really need it on a day-to-day basis... I was wondering how in the world can i stop this, since i don't see an option for it anywhere in the settings, and I already went to msconfig and unchecked the Hamachi box in startup, and couldn't find any mention of Hamachi in the services tab.... Despite all this, Hamachi still runs every time i boot my computer...

The only solution i currently can think of is uninstalling Hamachi and reinstalling it each time i need to use it... 

Is there anything that can be done to make Hamachi stop auto-running at startup short of uninstalling it?

 

thanks in advance.

New Contributor
gr33nman
Posts: 1
0

Re: Stop Hamachi from auto-running

I need to know: how do you set hamachi 2 to NOT start when windows starts? I see no setting for this. I have to physically turn if off every time I reboot. It didn't used to be this way. Am I missing something?
New Contributor
TechJedi
Posts: 1
0

Re: Stop Hamachi from auto-running

I found a way to do this:

1) Right click on "My Computer".  Select "Manage".

2) Click on "Services and Applications" and then on "Services".

3) Inside the services screen, scroll down to "LogMeIn Hamachi 2.0 Tunneling Engine"

4) Double click on it.  Then change the "Startup Type" to "Manual".  Click okay.

 

That should do it.

New Contributor
Thakmere
Posts: 1
0

Re: Stop Hamachi from auto-running

Thank you, you are a saint.

 

This is the only way this works that I've found.

 

And for those of you who can't/don't want to do that:

instead of uninstalling and reinstalling each time, you can just go to the application and put it in a rar file (as stored) and just delete the real file, that way you can just extract it each time you need it. Much easier and simpler than re-installing. I haven't tested it, but it's never failed in the past for me.

 

or change the .exe to something else. Whatever works for you...

New Contributor
taersious
Posts: 1
0

Re: Stop Hamachi from auto-running

@echo off

TITLE START LogMeIn Hamachi Service
COLOR 3F
NET START Hamachi2Svc
 
save this to a batch file here:  "C:\ProgramData\Microsoft\Windows\Start Menu\Programs"  (startHamachi.bat or whatever)
 
Then go to Services.msc and change "LogMeIn Hamachi Tunneling Engine" to start "Manual".

This will make is so that hamachi does not fire up when you boot/logon your pc. When you want to start hamachi, just run that batch file from the Start menu.
New Contributor
Gorgrak
Posts: 4
0

Re: Stop Hamachi from auto-running

Please view my post here for another way to disable it:

t5/Hamachi/No-exit-button-any-more-Won-t-exit/m-p/105095#M10347

New Contributor
Knexiii
Posts: 1
0

Re: Stop Hamachi from auto-running

Or just use this code in a bat file:

 

@ECHO OFF

::If Hamachi is running then it will stop it. TASKLIST /FI "IMAGENAME EQ hamachi-2.exe" | find /i "hamachi-2.exe" IF ERRORLEVEL 0 sc stop Hamachi2Svc GOTO START
::If not running then it will start it. :START sc config Hamachi2Svc start= demand sc start Hamachi2Svc

 

New Contributor
IanM_56
Posts: 1
0

Re: Stop Hamachi from auto-running

[ Edited ]

Is there a way to automate this for future updates?

 

---

 

By the way.

 

Use

 

ELEVATE sc config Hamachi2Svc start= demand

 

In command-line to change startup type.