Reply
New Contributor
pancakemix
Posts: 1
0

Turning "Relayed tunnel" into "Direct tunnel"

Hello, I am currently trying to play games with my friends using hamachi. While all my friends have a "Direct Tunnel" to eachother i am connected to them with a "Relayed Tunnel". Could someone tell me how to change this into a direct one? I've been searching the web for a while to find a fix but all the solutions seem to be outdated. Could someone please help me?
New Contributor
ChichaSRB
Posts: 1
0

Re: Turning "Relayed tunnel" into "Direct tunnel"

I have the same problem!Did you find solution?I need help very bad, i cant play games with my frieds because of relayed tunnel!Thanks in advance...

New Contributor
Pandamore
Posts: 1
0

Re: Turning "Relayed tunnel" into "Direct tunnel"

I have a problem with pinging other people, I get request timed out.

After some tweaking and reading stuff about those firewall things, I got my icons on other people from blue (relayed tunnel) to green (direct tunnel).

I'm not sure how, but these are the things I did.

In Hamachi > System > Preferences > Settings > Advanced Settings > Peer Connections

Local UDP Address > Smaller Box : 45565

Local TCP Address > Smaller Box : 45566

And in my router settings, I portforwarded 45565 for UDP and 45566 for TCP.

I also allowed them in my Inbound Rules and Outbound Rules on my W7 Firewall.

Hope this helped.

New Contributor
russo922
Posts: 1
0

Re: Turning "Relayed tunnel" into "Direct tunnel"

where di you get the udp adrress and the tcp

 

Trusted Contributor
Posts: 209
0

Re: Turning "Relayed tunnel" into "Direct tunnel"


russo922 wrote:

where di you get the udp adrress and the tcp

 


pref.JPG

 

settings.JPG

 

advanced.JPG

 

udp.JPG

New Contributor
gustaz
Posts: 1
0

Re: Turning "Relayed tunnel" into "Direct tunnel"

If you do not have a router or port forwarding is too difficult for you and you have turned firewall off and one thing to fix there is another way by trying to turn your anti-virus off but it is risky before turning it off always scan if there are no viruses and then restart hamachi after that almost everybody except for those who always have been relayed will get direct.

New Contributor
Ale3ander
Posts: 1
0

Re: Turning "Relayed tunnel" into "Direct tunnel"

Same prob.

 

Did all said before.

 

We had direct tunnel after we portforward to the same ports. After a week or so we had relay once again. WTF? Sometimes with a triangle next to it.

 

We both re-install and went the whole situation from the start.Fixed the triangle thinky. Not the tunnel though.

 

We now have 175ms with 600-700ms spikes.

 

I really want 60ms once again!!!!

 

Thanks in advance to anyone who will fix my problem.

 

 

Encryption : Dis

Compress : Any

Protocol : Both

Traffic: all

TCP/UPD : To my liking

Disable UPnP : no

 

Portforwarded to hamachis ip (to the new one every time after re-install)

Firewalls : Down both when using hamachi, even if i have addded the exeptions to both.

 

 

 

New Contributor
davikhale
Posts: 1
0

Re: Turning "Relayed tunnel" into "Direct tunnel"

I hate to necro-post, but I had small bit of input. Hopefully you have figured it out before now, but I get the same thing if i'm using a wireless connection. I believe to have a direct tunnel you must be using a wired connection to have a direct tunnel.

New Contributor
bandito
Posts: 1
0

Re: Turning "Relayed tunnel" into "Direct tunnel"


davikhale wrote:

I hate to necro-post, but I had small bit of input. Hopefully you have figured it out before now, but I get the same thing if i'm using a wireless connection. I believe to have a direct tunnel you must be using a wired connection to have a direct tunnel.


I'd like to agree to know the cause, but can't say that's always been the case. I have a fleet of laptops (& Ubuntu servers, some wired LAN) and this lack of direct tunnel began about a year ago. Nothing's changed on my end for years, except OS updates. hmmm...

New Contributor
zeroFX
Posts: 1
0

Re: Turning "Relayed tunnel" into "Direct tunnel"


davikhale wrote:

I believe to have a direct tunnel you must be using a wired connection to have a direct tunnel.


I have to disagree with that, simply because on the network protocol level, at which Hamachi is working, is way below the levels that have anything to do with a connection being wired or wireless.

 

Metaphorically spoken, that would be like implying that people cannot understand one another, if their messages are transmitted through a wire, but they would if transmitted face to face only through air. (ok, maybe not exactly a good metaphor, but anyway.)