cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Attendees now need Mac OS 10.8 Mountain Lion to participate?

I can't believe what I'm reading!!!
Just received an invitation to participate in an upcoming webinar and the system requirements for attendees is Mac OS 10.8 Mountain Lion.
Is Citrix trying to get GoToWebinar to self destruct?
I can't even get attendees to upgrade from Mac OS10.6 becausethey loose too many necessary features even just going to Mac OS10.7 and now they areexpected to upgradeto OS 10.8 just to participate.
5 REPLIES 5
LogMeIn Manager

Re: Attendees now need Mac OS 10.8 Mountain Lion to participate?

Hi Kurt,

Sorry, that was a mistype that should be corrected shortly. Attendees are required to have OS X 10.7 or newer to run the GoToWebinar desktop software, otherwise they will join directly through their web browser via our web app.
Glenn is a member of the LogMeIn Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
New Contributor

Re: Attendees now need Mac OS 10.8 Mountain Lion to participate?

Thanks for the quick reply Glenn, much appreciated.

As to attendees joining via a web browser, I was told a while back that for the Mac only Chrome is supported as a browser -is that still the case?
Most people I know use either Safari or Firefox as their primary browser with the Mac; Chrome is frowned upon because of the tracking it does which many people don't like.
LogMeIn Manager

Re: Attendees now need Mac OS 10.8 Mountain Lion to participate?

Chrome or Firefox will work. Chrome has the best HTML5 support currently so we are able to add features like the built in VoIP to it first. As we continue to develop our Web App we will add support for VoIP in Firefox and support for Safari.
Glenn is a member of the LogMeIn Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
New Contributor

Re: Attendees now need Mac OS 10.8 Mountain Lion to participate?

I'm chiming in on this thread because the thread directly related to my comment was closed to further comments.

I'm still running Mac 10.6.8 and, although I "get" the whole idea of not extending further support to older systems/browsers, I do NOT understand why you had to kill the audio altogether, forcing me to have to dial in on my phone to hear audio from a webinar I choose to watch on my desktop monitor (vs. a 5-in screen.)  What does one have to do with the other?  You're saying that you can continue to offer screen visualization as an attendee but not AUDIO, just because you're no longer 'supporting' 10.6?

Excuse me but I just don't buy that.  The audio is the LEAST demanding piece of the puzzle - there was no need to completely disable that portion of the functionality and then claim it's because you're "no longer offering support."

I'm not sure you guys realize it or not but there are other options in the marketplace.  Technology moving forward is a reality; deliberately disabling functionality of an existing product and then attempting to deceive the marketplace is a negative business practice, one I would recommend your company drops from its mantra for its future immediately.
LogMeIn Manager

Re: Attendees now need Mac OS 10.8 Mountain Lion to participate?

Hi David, if you are talking about joining via your web browser, audio is supported with the Chrome web browser. We are using WebRTC to create our web based clients and currently Chrome has the best compatibility and is the easiest to develop for. We are working to add audio support to the other web browsers currently.


http://support.citrixonline.com/en_US/meeting/all_files/G2M030006
Glenn is a member of the LogMeIn Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!