Showing results for 
Search instead for 
Did you mean: 
Active Contributor

Re: Hamachi can't run on m1 Mac

After looking at the details of setting up a kext for use of Hamachi on my M1 Macbook Air, I found that the extensions provided by Logmein have not been updated since 2019 and do not have the required executable for arm64e.


I did get Hamachi running by using the mobile client setup.  Works well.  You will not get an interface using this method; however, connectivity is fine.


WARNING: This solution is not standards compliant and may expose your computer to risks. Only try this on a computer that is not mission critical.


Basic instructions:

From Logmein web page:  add mobile client

email settings to mac m1

add three files to keychain

trust all certificates and keys and allow access from all applications

on Hamachi Smartphone client, set Access Control  (I used Allow all - you might want to limit)

Network settings add Cisco IPSec VPN client

Fill in server address, account name and password.

Authentication Settings

Certficate Select Hamachi Smartphone Client

I left Group Name blank


I put and In DNS Servers tabs (Advanced) - later deleted - not needed.



Active Contributor

Re: Hamachi can't run on m1 Mac

Good find, dude.  Not sure why I didn't think of that myself

Active Contributor

Re: Hamachi can't run on m1 Mac

I appreciate your work on this but unfortunately I get a unexpected error message. 

Active Contributor

Re: Hamachi not supported on macOS Big Sur

let's hope this is true.

3 months to the one year anniversary since M1 was released,...and it being August 2021,.... I created a ticket to inquire and received this (Customer Support):


"It not available yet, but will be. At the moment we don't have an estimated time of wen it will be released."

🙏 🙏 🙏 



Active Contributor

Re: Hamachi can't run on m1 Mac

“Unexpected Error” is usually related to certificate problems.  Recheck your keychain trust settings for three certificates and one private key.  (Right click certificate, Get Info, >Trust > Set all items to “Always Trust”; for Private Key set Access control to “Allow all …” ) Since this is a “hack” using non standards compliant certificates, I can’t really give any detailed advice.  Make sure you are using the Cisco VPN (look at the “preview IOS config”on the logmein add mobile client page).
Fill in the Join Network box.
Select protocol IPSec

Select “filter …”


Verified on MacOS 11.5.2. — I also had problems with this solution 4 months ago on an earlier OS.

Active Contributor

Re: Hamachi can't run on m1 Mac

Thanks. I checked and rechecked the settings but I still receive the error.  Console reports a series of raccoon errors but the first is: 


get_x509cert error -25300 errSecItemNotFound.

Active Contributor

Re: Hamachi can't run on m1 Mac

I tested my connection from MacBook Air (M1) to Windows XP port 5900; Windows 10 - realVNC and to Debian Linux Stretch (armhf) using ports 80 and 22.  All worked OK.  The ssh -vvv command of ssh showed that the exchange keys were not present and reverted to “authmethod_lookup password”.


I have had some stability issues with this connection.


Good luck on getting connected.  This solution is not for everyone.

New Contributor

Re: Hamachi can't run on m1 Mac

Hi Terry,


I managed to get things working on my 2nd attempt iMac (24", M1, 2021) Big Sur 11.5.2 - thank you for the tutorial !


This also appears to be the only way to access Hamachi via VM (Windows10_InsiderPreview_Client_ARM64_en-us_21354.VHDX) inside Parallels Desktop 17 (no need to install Hamachi for widows, which doesn't work via VM)


Steps : 

1) Go to -> Add client -> Add mobile client -> Client name (M1_Mac) -> Create

2) -> My Networks -> (Network_name) -> Clients -> Members -> Add/Remove Members (M1_Mac)

3)  -> My Networks -> (Network_name) -> (M1_Mac) -> Edit -> Mobile


4) Personally I ticked both "Connection protocol" : IPSec + PPTP Save

5) Note the  "Device configuration" : (User ID) (Password) (Server address =

6) Fill in "Send configuration via email to:" -> Send Other


7) Open the email "Here's the LogMeIn Hamachi Configuration file you requested. Open the attachment on the  device to apply the configuration." and Drag/Drop all 3 certificate files : HamachiRootCA.crt, HamachiIntCA.crt, hamachi-nnn=nnn-nnn.pfx


10 ) Open Keychain -> System Keychains -> System

9) Drag and drop all 3 into the System Keychain

(sometimes TouchID worked, sometimes I had to type in my Administrator username/password)


10) Right click each of "LogMeIn Hamachi Root CA", "LogMeIn Hamachi Intermediate CA256", Hamachi Smartphone Client nnn-nnn-nnn"

11) For all three -> Trust -> When using this certificate -> Always Trust

12) For "Hamachi-nnn-nnn-nnn" private key -> Get Info -> Access Control -> Allow all applications to access this item -> Save Changes


13) System Preferences -> Network -> Unlock -> "+" -> Interface : VPN, VPN Type: Cisco IPSec -> Create

14) VPN (Cisco IPSec) : Server Address: / Account Name : (User ID) / Password:  (Password) from Logmein's "Device configuration"

15) Authentication Settings... -> Certificate -> Select -> Hamachi Smartphone Client nnn-nnn-nnn

16) Tick Show VPN status in menu bar -> Apply -> Connect


Windows 10 ARM insider preview in Parallels 17 does work over Big Sur's Hamachi VPN, but is extremely slow, like "via relay" speed.


The VPN connection appears to be limited to about 55minutes, in which time the VPN connection drops.  I don't know if this is an OS11 problem or a Hamachi limitation

New Contributor

Re: Why isn't Hamachi compatible with M1 Based Macs?

they need to fix it my friend is trying to use hamachi and it doesnt work with m1 macs

New Contributor

Re: Why isn't Hamachi compatible with M1 Based Macs?

Hi all

Unfortunatelly Terry's solution doesn't work for me, I'll try it maybe again later...

But this is really frustrating, it has been now 10 (ten) months since the release of first M1 devices, and still no updates from Logmein on this one!!!