Showing results for 
Search instead for 
Did you mean: 
New Contributor

Game won't detect hamachi IP

Me and my friends started to play Far cry 2 on LAN again, its me that usually hosts the server since my i'm the only one who uses an ethernet cable instead of wifi, but it seems that if I host the game my friends can't find my server or join it, but if another of my friends hosts it I can join it no problems.

I noticed that in-game after you create a server it shows the server's IP adress after the name, at my friends server name its fine the game uses the hamachi adress, but mine seems to use my ethernet ipv4 adress (

I've tried everything, since adding hamachi to the firewall since it wasn't there yet for some reason, the game is also unblocked on the firewall, tried reinstalling hamachi severall times to no avail, reinstalled the game aswell but it didn't work, the priority is set at the top by putting the metric to "10". I've got no ideia whats wrong does anyone know how to fix this?



EDIT: I found a temporary solution, if I disable my ethernet adapter start the game and enable it again the game detects the hamachi IP

New Contributor

Re: Game won't detect hamachi IP

Hey kursed_mc

Thank you very much for your Post! Kind of disappointing that you didn't get any sort of answer for this issue - even tho it seems to happen to lots of us... Anyways, your last edit about disabling the Ethernet connection finally let me and my friends play Anno 1701 together after a long evening looking for answers to solve this problem.

Big thanks from all of us <3