Welcome to the Hamachi Community!
Reply
New Contributor
Posts: 6
Registered: ‎04-05-2017

Hamachi going offline (paid!)

Hi

We have Hamachi installed on 4 servers and numerous clients to connect to the windows servers via RDP

 

One server has recently started going offline on hamachi - as if the client is turned off via the "power" icon.  Logging on locally shows the client is "off", and clicking it is all fine.

 

Product is paid for and licensed and should be OK!  it is OK on other servers.

 

Client is up to date, and has been removed/reinstalled via different methods.

 

Any suggestions on where to go from here?  Any log files?  Any settings to stop client going offline?

 

Server is Win 2008

New Contributor
Posts: 6
Registered: ‎04-05-2017

Re: Hamachi going offline (paid!)

Hmmm

 

The log file has some interesting bits in - this is *pronbably* when it vanished.  It mentioned a netgear UPnP device - but I'm *certain* this servrer is plugged into an unmanaged basic netgeat GS108 type switch, and from there to a Draytek router.  No managed netgear I'm aware of

(though will look under desks next time I'm there!)

 

Log below.

 

04/05 17:59:25.853 [8460] tcp: http socket 760
04/05 17:59:25.853 [8460] pnp: cancel(034f7750)
04/05 17:59:25.853 [8460] pnp:  1 active requests, waiting 2000 ms ..
04/05 17:59:25.857 [8460] pnp: received 00000000 response part, 562
04/05 17:59:25.857 [8460] pnp: received 00000000 response
HTTP/1.1 500 Internal Server Error

EXT:

CONTENT-TYPE:text/xml

SERVER:Linux/2.6.12 UPnP/1.0 NETGEAR-UPNP/1.0

CONTENT-LENGTH:428

 

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">

<s:Body>

<s:Fault>

<faultcode>s:Client</faultcode>

<faultstring>UPnPError</faultstring>

<detail>

<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">

<errorCode>714</errorCode>

<errorDescription>NoSuchEntryInArray</errorDescription></UPnPError>

</detail>

</s:Fault>

</s:Body>

</s:Envelope>

 


04/05 17:59:25.857 [8460] pnp: 034b92c0 request FAILED, rc -2
04/05 17:59:25.954 [8460] pnp: term() completed
04/05 17:59:26.244 [12252] tap: device found, status enabled, running
04/05 17:59:26.245 [12252] vpn: disabling tap device ..
04/05 17:59:26.245 [12252] tap: do_status(ROOT\NET\0000, 0) ..
04/05 17:59:27.896 [8460] ses: on_ip_change()
04/05 17:59:29.094 [8460] ses: on_rt_change()
04/05 17:59:29.220 [12252] tap: SetupDiCallClassInstaller() ..
04/05 17:59:29.325 [8460] ses: on_rt_change()
04/05 18:00:02.646 [12252] tap: do_status(), rc 1
04/05 18:00:02.647 [8460] tap: job [Hamachi, JOB_set_tapdev, 0] done, result: success
04/05 18:00:02.647 [8460] vpn: on_set_tapdev(Hamachi, 0) -> ok
04/05 18:00:02.648 [8460] vpn: domain [Hamachi] -> 'VPN_disabled'
04/05 18:00:02.648 [8460] dbg: setup_vpn_domain [Hamachi]
04/05 18:00:02.648 [8460] dbg: vpn_domain::config - [Hamachi]
04/05 18:00:02.649 [8460] tap: job [Hamachi, JOB_set_tapdev, 0] start thread ..
04/05 18:00:02.649 [3692] tap: job [Hamachi, JOB_set_tapdev, 0] thread started
04/05 18:00:02.650 [3692] tap: set_tapdev(Hamachi, down) ..
04/05 18:00:02.650 [3692] tap: list_netdev_win32() ..
04/05 18:00:02.767 [3692] tap: device found, status disabled, not running
04/05 18:00:02.767 [3692] tap: already in a requested state
04/05 18:00:02.768 [8460] tap: job [Hamachi, JOB_set_tapdev, 0] done, result: success
04/05 18:00:02.768 [8460] vpn: on_set_tapdev(Hamachi, 0) -> ok
04/05 18:00:02.769 [8460] dbg: setup_vpn_domain [Hamachi]
04/05 18:00:02.769 [8460] dbg: vpn_domain::config - [Hamachi]

New Contributor
Posts: 6
Registered: ‎04-05-2017

Re: Hamachi going offline (paid!)

Same server just disabled itself, and another (W2012R2) has done the same, but the log is very different.

 

Anyone have any ideas?!

LogMeIn Contributor
Posts: 59
Registered: ‎01-17-2017

Re: Hamachi going offline (paid!)

Hmm interesting, have you tried seeing if the Hamachi service itself crashes or if it's the whole UI. If it's just the service that stops you might be able set the service to recover.

 

services.msc > Properties > Recovery

New Contributor
Posts: 6
Registered: ‎04-05-2017

Re: Hamachi going offline (paid!)

Hi

No, service running OK, and UI was actually running, but just "powered off".  Same on both servers.  Restarting service made no difference.  Only was was to click "poower on" button on UI

 

Do you know if this can be done from a script/tool/command line? 

 

 

Interestingly, on the server I posted the log yesterday, I did a LAN scan and found an old netgear router being used as just an AP - e.g. wifi AP connected to LAN switch.  No broadband connected.  It was on a different subnet and in theroy the server should not know it exists, but it appears the router was advertising uPnP, and indeed there were uPnP sessions grabbed by the router from the server (!).  So I've disabled uPnP on that router as if it was getting in the way, of course something would break.  If it still crashes I'll get it unplugged.  The log above mentions Netgear uPnP hence feeling confident.

 

The other server that powers hamachi off has a different log and no mention of a crash so can't figure that one out....

New Contributor
Posts: 6
Registered: ‎04-05-2017

Re: Hamachi going offline (paid!)

FFS

The Server near the netgear box has gone off line again , but no way to connect to check teh logs.  Argh.

 

Oh - and lovely getting support from LMI - zero response from a support email!  Thanks.

Highlighted
Contributor
Posts: 6
Registered: ‎10-20-2015

Re: Hamachi going offline (paid!)

We have the same on our client computers. Hamachi poweroff himself. Only with a Power-on click it logged on again. I also don't get it why there is a power on/off button if you run hamachi by services. The services run, but a client can overrule by clicking power-/loggoff button. Bye bye connection.

 

We also asked support to change this or make a command option to auto poweron hamachi interface we can builld in a script. But no support from here, and we also have a paid account with 999 clients.

 

New Contributor
Posts: 4
Registered: ‎06-29-2016

Re: Hamachi going offline (paid!)

have the same Problem spread over many Companys , some Clinets and Servers switches semselfes to Offline like somebody Push the Power Off Button. Everything is Licenced and Paid. This is a Often Common Problem.