Welcome to the Hamachi Community!
Reply
Valued Contributor
Posts: 37
Registered: ‎03-30-2015

Re: Windows 10 Hamachi drivers not installing


VideoSavant wrote:

Thanks for the clarification on versions, Aquitane. I've gone back and followed the instructions according to version number, step by step, but still no luck. After completing the first 6 steps, I unchecked the QoS setting and rebooted. First time, no luck. Second time I restarted, still no luck.

 

I tried reinstalling the hamdrrv, and I was able to see the two Hamachi adapters display the "Identifying..." message, and eventually that timed out on both adapters with the "Unidentified Network" message.

 

I am also on Windows 10 build 10061. 

 

I suppose I will try to rebooting a couple more times, but I feel that "doing the same thing/surprised to be getting the same results" thing heading in my direction.

 

Let me know if you have any other ideas or suggestions for me.

 

Thanks again! 


All right, here's a trick I just verified on my system at home. (Remoted in through Bomgar while on the road).

 

Before uninstalling version 319 and reinstalling, copy the hamdrv.inf (must be dated 2/17/2015) from the Hamachi install to your desktop (or anywhere you want). While reinstalling Hamachi 319, right click the saved hamdrv.inf and install while the installation of Hamachi is running. Your installation should come up connecting without having to uncheck QOS or IPv4 or IPv6.

 

I have done this twice now on my system at home running 10061 and this works on my Surface Pro running 10049 (don't have the bandwidth to update to 10061).

 

Give it a try and report back

Richard I

Valued Contributor
Posts: 39
Registered: ‎04-23-2015

Re: Windows 10 Hamachi drivers not installing

Richard,

 

Thank you VERY much. Your trick did the trick. 

 

I am now connected and my proxy is back in operation. Not sure how you came up with that trick, as that's something I never wouild have thought to try. 

 

FWIW for anyone else attempting this, I waited to do the manual install of the hamdrv just as the install program was getting to the "Installing driver" portion of the process, which in fact happens pretty quickly.

 

Again, thank you so much for this suggestion. It is a pleasure to no longer be beating my head on my desk!

Valued Contributor
Posts: 37
Registered: ‎03-30-2015

Re: Windows 10 Hamachi drivers not installing


VideoSavant wrote:

Richard,

 

Thank you VERY much. Your trick did the trick. 

 

I am now connected and my proxy is back in operation. Not sure how you came up with that trick, as that's something I never wouild have thought to try. 

 

FWIW for anyone else attempting this, I waited to do the manual install of the hamdrv just as the install program was getting to the "Installing driver" portion of the process, which in fact happens pretty quickly.

 

Again, thank you so much for this suggestion. It is a pleasure to no longer be beating my head on my desk!


I figured it out because I was impatient. The reinstalls always hung at the network installation and I wanted to "help it" along. I was a bit surprised at the result.

 

Richard I

Contributor
Posts: 8
Registered: ‎11-17-2013

Re: Windows 10 Hamachi drivers not installing

Your process worked.  Here are the details that I did based off of your posts

 

Windows 10 Build 10061

Hamachi version 2.2.0.328

 

Copy the hamdrv.inf file out of the folder where Hamachi is installed and put it on desktop for easy access.

Uninstall Hamachi

Reinstall Hamachi

Wait until Hamachi install gets to the "Status: Installing Network Adapter"

Right click on the copied hamdrv.inf file then left click on install.

You will receive a small window saying that the install was complete (hamdrv.inf)

The install of Hamachi will complete.

Make you normal setup changes (Name, Network, Hide Offline, etc etc)

 

I did not have to make any QoS changes or IPv4......

 

Valued Contributor
Posts: 39
Registered: ‎04-23-2015

Re: Windows 10 Hamachi drivers not installing

Hate to say this, but I'm back to beating my head on my desk. 

 

I had to reinstall Windows due to the fact that I just completed a new computer build. Now, when I follow the instructions that worked for me the last time I was faced with the Hamachi brick wall, it doesn't work. The problem occurs when I click Install on the hamdrv.inf file (dated 2/17/2015), I get a system message as follows:

 

"The third-party INF does not contain digital signature information."

 

Not sure why this is suddenly appearing, but it is happening consistenly. I even turned UAC off, thinking this might be a Microsoft busy body security issue, but even with UAC off, I get the same message.

 

Because this worked before and doesn't now, I'm more than 50% sure that I'm doing something wrong, but re-reading the instructions and re-tracing my steps brings no resolution.

 

Any suggestions?

New Contributor
Posts: 3
Registered: ‎04-27-2009

Re: Windows 10 Hamachi drivers not installing

Thanks for those instructions IBTECAdmin. I'm on slow ring and just went from 10049 to 10074 today and lost my Hamachi network adapter. Followed your instructions and everything is up and running again. Like you, I didn't have to make any changes to QoS, IPv4, etc...

New Contributor
Posts: 3
Registered: ‎04-27-2009

Re: Windows 10 Hamachi drivers not installing

The hamdrv.inf I used came from installing 2.2.0.328. The file was created 3/30/2015. That one didn't give me any signature issues.

Valued Contributor
Posts: 39
Registered: ‎04-23-2015

Re: Windows 10 Hamachi drivers not installing

[ Edited ]

Thanks, TracerX. 

 

The idea of using the .INF from the previous version had occurred to me, but since it was specified here that it needed to be the 2/17/2015 file, I hadn't made it a priority. But once I saw that it worked for you, I gave it a try, but I'm still getting the message about the digital signature missing. Maybe there's a Windows parameter I can turn off to defeat that issue...

 

Back to Google...

Valued Contributor
Posts: 39
Registered: ‎04-23-2015

Re: Windows 10 Hamachi drivers not installing

OK, I found a solution to my driver signature issue. Note that the fix for this (documented at the top of Google search entries for defeating digital signature) used to be done through the Group Policy Editor. However, that is changed under Windows 8 and Windows 10, and the process for supressing digital signature enforcement is now done via the modern PC Settings console, as detailed here:

 

http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-s...

 

Making this change allowed me to force install the network drivers and I'm back in business with Hamachi and my proxy. 

 

Thanks again...hope this helps someone.

Contributor
Posts: 23
Registered: ‎09-20-2011

Re: Windows 10 Hamachi drivers not installing

I was working fine on two previous builds but now on 10074 I get nothing - no matter when I do the INF install, nothing apears in the network adapter list. I've uninstalled and reinstalled three diferent versions and even deleted Hamdrv.sys and registry entries for it - it just won't appear. :-/