Reply
Active Contributor
Posts: 4
Registered: ‎01-04-2016

inbound traffic block, check firewall settings

[ Edited ]

Recently had to reformat my computer. Upon reinstalling hamachi I find that i can't ping anyone on my list anymore. Before I reformated, it was perfectly fine. Here is an exactly of what the diagnosis told me when I ran it on someone.

 

Hamachi self-diagnostic result file
Date2016 - 01/04 18:12:51.454

Summary report
------------------------

Test name: Peer        Result: [RED] -> Problems found
Details:

Tunnel:
    VPN domain's tap device is down
    
Local results:
    Adapter configuration:
            Cannot get adapter config
    Traffic test: Cannot complete test
Peer results: [191-632-946]
    Adapter configuration: OK
    Traffic test: Inbound traffic blocked, check firewall settings

 

I have NO idea how to fix this. Any ideas?

 

Also if it helps when I go into my network settings hamachi isn't showing up there. At all. Only thing there is my internet connection I use. It was there before the reformat. Maybe that has something to do with it?

 

Update: Went to Device Manager to check out the Hamachi network there and saw this when ichecked out it's properties:

 

Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)

Active Contributor
Posts: 4
Registered: ‎01-04-2016

Re: inbound traffic block, check firewall settings

Bump

Advisor
Posts: 208
Registered: ‎11-06-2015

Re: inbound traffic block, check firewall settings

Try going the device manager, on the menu Action, add a legacy hardware; install the hardware manually from a list, select network adapter, clic Have Disk... button and point it to Program Files, Logmein Hamachi and select hamachi.inf file.


*************************************************
"If my post answers your question, please mark it as an "Accepted Solution."



"At this point in time, the Internet should be regarded as an Enemy Weapons System!"
Active Contributor
Posts: 4
Registered: ‎01-04-2016

Re: inbound traffic block, check firewall settings

hmm..... nope. thanks for trying to help, but for some reason it refuses to work still. :-/

Advisor
Posts: 208
Registered: ‎11-06-2015

Re: inbound traffic block, check firewall settings

"Recently had to reformat my computer"

 

Any chance your last installation was 32 bit and this time it installed 64 bit Windows?


*************************************************
"If my post answers your question, please mark it as an "Accepted Solution."



"At this point in time, the Internet should be regarded as an Enemy Weapons System!"
Active Contributor
Posts: 4
Registered: ‎01-04-2016

Re: inbound traffic block, check firewall settings

it was 64 bit when i reformated and afterwords.

New Contributor
Posts: 4
Registered: ‎08-09-2016

Re: inbound traffic block, check firewall settings

Solved : Step by step

1.- Go to windows firewall
2.- Advanced settings
3.- Windows firewall properties
4.- Public profile (if your hamachi network is public,or private profile if it's private)
5.- Protected Network connections
6.- Uncheck hamachi
7.- Done

Do that in every computer with windows 10

New Contributor
Posts: 1
Registered: ‎02-10-2017

Re: inbound traffic block, check firewall settings

This is probably a bit late but if anyone still experiences this problem then you can follow this step by step

 

1. Search "Firewall with Advanced Security" through Start Menu

2. Click Inbound Rules

3. Click New Rule on Left Hand Side

4. Select Program

5. Click Browse and find where Hamachi is Installed (if you're running 64 bit then there will be a x64 folder       otherwise if you're running 32 bit you'll see it straight away)

6. Click "hamachi-2-ui" and continue

7. Change from "Block the connection" to "Allow the connection"

8. You can decide whether this rule applies to all 3 (i reccomend all 3 though)

9. Name the rule "Hamachi" or whayever you want. description is optional

10. Do step 3-9 with Outbound Rules instead

 

And then you should be done and hamachi should work.

Hopefully this was helpful

 

Highlighted
New Contributor
Posts: 1
Registered: ‎11-12-2015

Re: inbound traffic block, check firewall settings

I tried the above without success but was able to sort it out by just removing the problem computer from the network, waiting a bit, and adding it back.  So much hair loss...