cancel
Showing results for 
Search instead for 
Did you mean: 
jcarden768
New Contributor

Admin Console is not working properly

Good morning, I am trying to assign newly purchased licenses to some employees through the Admin console but every time I go to the page I am automatically redirected to the purchase LastPass page. On this page it even shows where I have already purchased 3 licenses and I do not need anymore. I have deleted cookies in my Chrome browser but that didn't help. I am still being auto directed to the purchase page each time I try to use the Admin console. Any ideas? Thank you.
6 REPLIES 6
jpenny84
Respected Contributor

Re: Admin Console is not working properly

There should be a support number that you can call. Its location can be found in this support article.


https://blog.lastpass.com/2019/09/need- ... bout.html/
AlanFr
New Contributor

Re: Admin Console is not working properly

Hello I have the same issue, I am automatically redirected to the purchase page although I bought 10 licences a few weeks ago. I created a case which has automatically closed although I did not get any answer. I contacted support to have a call without success. Maybe this is due to the fact that I am located in Europe.

RachelO
Retired LogMeIn Contributor

Re: Admin Console is not working properly

Hi @AlanFr

 

You should be able to access the support phone number through your LastPass Admin Console > Support (the number should be on the right side column) or if you can't access the admin console you can request a callback by scrolling down and clicking "Contact Support" on this page and entering your business account info and you should then be given the option to receive a callback usually within less than 5 minutes: https://support.logmeininc.com/lastpass/help/how-do-i-contact-customer-support-for-lastpass-lp010121 




RachelO is a member of the LogMeIn Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudos!
AlanFr
New Contributor

Re: Admin Console is not working properly

Hi Rachel,

 

Since several weeks I try to contact US or French support.

I finally get an answer from US after several weeks via call back request yesterday! They didn't find the cause but at least they tried to help. 

No news from Europe yet.

 

 

PaulKelly1
New Contributor

Re: Admin Console is not working properly

I am having the same problem. Are Enterprise users entitled to contact support)

 

I live in the UK and cannot find  any way to contact LastPass support. Sales have not replied to my email.

 

Its not a great advert.

 

Do we know if there support teams even look at this site.

AlanFr
New Contributor

Re: Admin Console is not working properly

Hello,

 

It took we a while before I get an answer (several weeks). In the meantime I opened several tickets, both in my native language (French) and in English.

I was finally called back by a very nice guy at 3 AM (his time !!!).

I am afraid there are rooms for improvement in the support.