Showing results for 
Search instead for 
Did you mean: 
Active Contributor

Amazon TOTP Push Notification to Authenticator App No Longer Working

I'm using an iPhone and recently, the push notifications for the TOTP codes have stopped working and now I have to always manually enter the 6-digit code.


I've deleted and re-setup my account and 2FA, but all to no avail.


I followed the following steps:


and was listed in the "Never Ask About TOTP-to-Push" section.  I deleted it, per the instructions, but still no change when I re-logged back into; I had to manually enter the 6-digit code.


Since then, however, even after multiple deleting and re-creating my 2FA and account in LP Authenticator, I no longer have a "Never Ask About TOTP-to-Push" section.  However, after logging in and entering the 6-digit code, I do get the browser popup asking me if I'm sick and tired of entering the 6-digit code and with the link to "Enable Push Notifications."


I click on the link to enable the notifications and then the message says "Great...scan the site or add it manually" to enable the push notifications.


But the site has already been added!


The only thing that's different now is that after I manually enter the 6-digit code, I am always getting the popup from the Browser extension asking me if I'm tired of manually entering the 6-digit code.


So how do I get the push notifications working again for



Active Contributor



Is there no one else experiencing this issue?

Are you getting push notifications for TOTP requests?



GoTo Moderator

Hi @Nusaram 

I apologize for the frustrations with authentication settings recently. 

Have you already tried disabling the LastPass Authenticator, before then re-pairing the app with your LastPass account? 



Ash is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
Active Contributor

Hello @AshC , yes, I mentioned in my original post that I deleted and re-created (yes, that also means re-pairing) my Amazon account several times.


New Contributor

@Nusaram, although I only use LastPass's password manager and not its authenticator, I believe that what @AshC was asking about was disabling and then re-enabling the LastPass Authenticator app itself, not simply deleting/re-adding Amazon TOTP within the app.