cancel
Showing results for 
Search instead for 
Did you mean: 
KViper_98
Active Contributor

App Fill Service Not Working on Android

I have tested this on different Samsung devices: Galaxy S8, Galaxy S10+ and now the Galaxy Note 20 Ultra 5G. 

Since the September Android Security Patch the LastPass App Fill service on Android has stopped working. Is there a known fix for this. The annoying part is the Developer contact on Google Play the email address: (removed so other do not try to use it- GlennD)  comes back with the following: Please note that our support team is unable to respond to this email, as this inbox is no longer monitored.

 

I have deleted the app cache and data for LastPass.

I have set the app to never sleep within the battery optimization.

 

The LastPass support page offers nothing in regards to the App Fill service. There is no mention of an acknowledgement of the App Fill service not working.

status.lastpass.com should at least mention an issue with the App Fill service. It does not.

 

Is the App Fill service no longer available for mobile devices?

Is this a known issue? If so, when is this expected to be fixed?

 

I would prefer not to reset the device back to defaults to test this out.

 

Does anyone have any other suggestions?

Tags (2)
5 REPLIES 5
GlennD
LogMeIn Manager

Re: App Fill Service Not Working on Android

Hi @KViper_98 

 

Please use the Contact Support options on our support site when you wish to open a ticket. I have removed the email address from your post so that others do not try to use it and and get frustrated when no one replies. 

 

What versions of Android OS are your devices running? One of the challenges with auto-fill on Android are the changes made in each new version of Android. The first thing I would suggest is opening the LastPass App > Settings > Autofill and cycle disabling and enabling autofill again. After the Security Patch you may need to give the app permission again.

 

Glenn is a member of the LogMeIn Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
KViper_98
Active Contributor

Re: App Fill Service Not Working on Android

Hello Glenn,

 

I have cycled the AutoFill service a few times. The AutoFill  service works for about an hour and then the application will indicate the service is disabled again. One thing I noticed it that the Android Oreo Autofill would not turn on, the only one I could toggle "Legacy" Autofill service.

 

I am not sure if this was a cause or not. Earlier this year in April, I swapped out my Galaxy S10+ for a Galaxy Note 20 Ultra 5G device (GPS failed in the device). I used the Samsung SmartSwitch to move from the S10+ to the Note 20 Ultra 5G. The AppFill/Autofill service has worked up to Sept 2021. The only changes to my phone are Android Security Updates and the LastPass update. I do not allow Google Play to auto-update my applications. I like to select when to update the applications. It was shortly after this time the Appfill/Autofill service stopped working.

 

I have restarted the phone into safe mode and cleared the partition table. Logged back into the application. Turned on the Appfill/Autofill service. After about an hour the service is disabled again. I removed the application from the phone. Restarted it and then re-installed the application fresh. The Appfill/Autofill service for Android Oreo is now enabled.  Attached screenshot.

Screenshot_20211105-140747_LastPass.jpg

 

The last thing I turned on was the "Enable Overlay Permission" as shown within the screenshot. I will test this out for the next few days.

KViper_98
Active Contributor

Re: App Fill Service Not Working on Android

Glenn,

 

After about an hour the Autofill legacy has been disabled again.  Refer to screenshot from the application. 

 

Screenshot_20211105-144334_LastPass.jpg

 

The auto fill is not working when using applications and within the Brave browser (chromium based). The notification icon across the top has disappeared as well. This has worked previously on Android OS 11 prior to the Android security patch level in September 2021. Is there a beta version of LastPass that is testing the Auto Fill / App Fill for Android that I can sign up for?

Nax
New Contributor

Re: App Fill Service Not Working on Android

Yes. I am having exactly same problem as you. Intermittently the legacy auto fill get disabled by not sure who...

I am using Samsung S21 Ultra
Using Samsung latest firmware.
Security update 1st November 2021
Lastpass version 5.2.1.7318
KViper_98
Active Contributor

Re: App Fill Service Not Working on Android

Within the last 30 days the Android security patch level was released: November 1, 2021. Since that update, the autofill service has been working properly. Not sure if there was any updates to LastPass during October. I am happy to report the AppFill/AutoFill is working again.

 

Samsung Galaxy Note20 Ultra 5G

One UI version 3.1

Android Version 11

LastPass version: 5.4.1.7572

 

The weird part is the Autofill with LassPass icon does not always show within the Notification area. I open up the app and the icon will reappear automatically.