cancel
Showing results for 
Search instead for 
Did you mean: 
louisvallance91
Active Contributor

LasPass iOS app constantly logging me out and asking for master password

Dear Community,

 

Over the last few months, I've noticed on a couple of occasions that my iOS LP app on my iPhone 12 is constantly logging me out and showing me the Email/Master Password prompt.

 

My security settings are as follows:

  • Use Face ID: YES
  • Lock Options: Immediately
  • Skip reprompt after login: 5 minutes
  • Auto Logout: Never
  • Clear Clipboard: 30 seconds
  • Log Out On Close: NO

The LP app will immediately log out if I swipe the app away from the recent apps list; otherwise, the app logs itself out after approximately one minute regardless.

 

I have tried disabling and re-enabling Face ID, which does not solve the problem.

 

I also have the LP app installed on my older iPhone 11 (running the same iOS 15.1) with the exact same app settings, and the log out issue does not happen.

 

has anybody else noticed this problem? It makes the app basically unusable because my master password is, for very obvious reasons, extremely long and gnarly.

 

Cheers,

 

Louis

28 REPLIES 28
LHinOz
New Contributor

in the other thread on this subject, Rachel answered as follows. Worked for me! Cheers

 

Re: iOS touch ID duration

Hello,

 

Could you double check these settings in the LastPass app? 

 

In the LastPass app, go to Settings > Security > adjust the Lock Options and Auto Logout settings (and make sure the Log Out on Close option is also turned off.) The Lock Options setting is how often you'd like to have the LastPass app require Face ID/PIN code/Touch ID verification, and the Auto Logout setting is how often the LastPass app will fully log out and require the master password to log in. For example, if you only want to have to use biometrics to unlock the LastPass app, you would set Auto Logout to Never and change the Lock Options to your desired time period--for example, you can set Lock Options to 24 hours to be prompted for biometric authentication every 24 hours.

 

If these settings are set correctly as explained above, we would recommend uninstalling the LastPass app, restarting your device, then reinstalling and re-enabling the above settings to your preference to see if that resolves this issue.

 
louisvallance91
Active Contributor

I found several support threads dealing with these options, and it does seem to solve the problem for some users. The reason I created this thread is because LP was locking me out despite following the tips you posted. If you check my first post you will see that I've already tried all of the things you suggested.

 

If/when the problem returns on my iPhone 12 I will definitely try reinstalling the app!

 

Cheers,


Louis

Dahmenator
Active Contributor

I've been having the same problem for a couple months now. It seems to have started with iOS 15, but the problem has persisted every time there's an iOS update or a LastPass app update. Sometimes I stay logged in, sometimes I don't. It appears to be quite random.

 

Additionally, I'm using Last Pass Authenticator, and each time I'm logged out I have to reselect "Trust this device" for 30 days, but immediately upon closing (but not quitting or logging out of the app) I not only have to re-enter my Master Password but I have to go through the Authenticator again, and Last Pass doesn't seem to remember that I instructed it to remember my device for 30 days.

 

My Security Settings

Use Face ID: On

Skip prompt after login: Disabled

Auto Logout: Never

Lock Options: Immediately*

 

*Tried changing this to other options (like 24 hours) but with mixed results. Sometimes I stay logged in, sometimes I don't. Just tested again with this setting set to 24 hours and after only a few minutes I was prompted to re-enter my Master Password.

 

Restarting my iPhone does not help, nor does reinstalling the LastPass app. This is beyond frustrating, especially since my Master Password is a long one. I can remember it, but it's a pain in the rear to retype EVERY time I need this app.

 

Hardware

iPhone 13 Pro Max

iOS 15.3.1

 

Dahmenator
Active Contributor

UPDATE:

 

Just got off the phone with LastPass Support (I'm a Premium subscriber) and they were able to get the issue resolved for me. They called me back within 15 minutes of receiving my support ticket. Very nice that I didn't have to wait 24 hours or try to troubleshoot all of this via email.

 

The Support Technician cleared out all my saved trusted devices on his end (he suspected some of them were corrupt), had me change some Account Settings in my LastPass plugin for Chrome, had me delete and reinstall the LastPass app on my iPhone, and finally reset my app Security settings. Everything works now like it did before this issue started.

 

If you're a Premium subscriber, I recommend reaching out to Technical Support and have them run through the same troubleshooting steps they did for me. If you're using the free version of LastPass, I don't know how support will work for you. My guess is email may be the only option but I could be wrong.

BlueSky114
New Contributor

Glad I found this thread as I've been suffering with this too and ready to ditch Lastpass.

I'm OK with the add- in on FireFox, but it's the iPhone (12 Pro Max) that's driving me nuts.

Funny, I also am a premium user and spoke with Lastpass support yesterday and only got some mumbo jumbo, nothing as helpful as you received.

I too am using an authenticator (Google).

Could you please share your settings?  I thought I will make sure I'm set up like yours and if that doesn't work I will call Lastpass support again.

Thanks.

Dahmenator
Active Contributor

Bummer about your Technical Support experience. I would definitely try again. Maybe you'll get someone else who's more helpful. As I said, I got a call back within 15 minutes, and he was on the phone with me for at least 20 minutes trying very hard to fix the issue, which he ultimately did.

 

I believe the main culprit was some outdated and/or corrupt authorized devices associated with my LastPass Account. He said there were about 35 authorizations, so he deleted them all on his end (something I could not do on my end), then had me re-authenticate on my computer and iPhone, then had me login to my LastPass Account in Chrome and adjust some Account Settings under Trusted Devices and Mobile Devices. Next, he had me delete the LastPass app on my iPhone and reinstall it, and finally we adjusted some Security Settings within the app. It took some doing but he got it done.

 

Here's the settings I'm currently using. When I woke up this morning I opened LastPass and it instantly logged me in with Face ID.

 

IMG_0065.PNG

BlueSky114
New Contributor

Thanks for the quick reply and info.

I'm trying the easiest thing first, I have deleted the app and  reinstalled it.

I've logged in and so far so good, it's been over two hours and I pulled it up on my phone and I'm still logged in.

Maybe there's hope.

 

Dahmenator
Active Contributor

👍

Glad you got it sorted. If it happens again, I'd recommend logging into your LastPass Account in Firefox, then go to Account Settings/Trusted Devices and Account Settings/Mobile Devices and either clear everything out in those two locations, or manually setting all to "Enabled".

 

If you clear everything out you'll have to re-authenticate on all your computers and mobile devices.

louisvallance91
Active Contributor

Hi all,

 

This issue has come back with a vengeance. I'm surprised that this isn't sorted yet. Anyway, I have followed Dahmenator's recommendation of clearing trusted devices (see attached). I also disabled all 2FA and re-enabled.

 

I'll update this thread to let you know if it sorts out the problem.

 

2022-02-22_15-43-44.png

fireboy
New Contributor

I just started having this problem in the last couple of days and it's annoying as hell.  I've been using LastPass for YEARS without this problem until now.

 

I did what @louisvallance91 showed above and mentioned by others here:  deleted all devices and and trusted devices, deleted and reinstalled the app on my phone and at least in limited testing after that it seems to be working again.  

 

Will see.