cancel
Showing results for 
Search instead for 
Did you mean: 
sam258
Active Contributor

Lastpass Authenticator deleted all accounts

I just tried to login to lastpass using lastpass Authenticator. I approved it on my Apple Watch and nothing happened. I tried a few times. I grabbed my phone which was charging, and opened lastpass Authenticator. It wouldn’t show me my codes when I opened it. It said “restore from backup” or “add a new code”. There was no way out of the prompt. I closed the app and opened it, still there. I clicked restore. Now all my 2FA logins are gone. Where did they go? I need them restored.
27 REPLIES 27
Tagg
Active Contributor

I haven’t had any issues since disabling notifications to LastPass Authenticator on my Apple Watch.IMG_6898.jpg

Lucsi
New Contributor

As soon i Accepted a connection from my Apple Watch it deleted all my accounts MFA from the phone. This is a live bug must be fixed
Andrew57jm
New Contributor

At this point it’s clear the developer doesn’t care and has no intention of fixing this bug, which has been reported since summer 2021. I have no problem as long as I don’t use the watch, and that’s what I do
Jov
New Contributor

Just saying ... I haven't read the whole discussion so this was maybe proposed at some point. 

 

I had the same issue.. and while I was trying to figure why authenticator was deleting the accounts, I saw that option not being activated in the lastpass application (not the authenticator): "Authorize Apple Watch". It was off.  (On the iPhone: Lastpass app / settings / security )

 

I first though this was not an option for the authenticator but fort lastpass anyway.. But since searching for the authenticator on the apple store returned no results on the watch on the opposite of the iPhone, I realized that the authentication on the watch was imbedded into the lastpass app for the watch. So on the opposite of the phone, the watch has only one application while on the phone that's 2 applications. That's maybe what created the confusion for many of you too since at first, I was thinking that lastpass and the authenticator were 2 different and independent apps on the watch too.

 

So anyway, I activated the option "Authorize Apple Watch" in lastpass on the iPhone and so far, so good. I had also activated "Use Apple Watch Pin Code" but this might not be related... just saying in case that makes a difference but I wouldn't see why.

 

So, so far so good... But hey, I haven't test it for days and even not hours... So who knows.. it can maybe still fail after a while.. Time will tell.. You have to try out .. 

 

As for the reason this happened, I'm on the impression that when the application is not authorized, there's a protection that deletes the accounts.. maybe.. Now the behavior is so important that we should have gotten a prompt to activate the option... 

 

Anyway.. good luck and if this works let us know!

 

J_Lim
GoTo Contributor

Check the version of the LastPass Password Manager you're on.

 

The release notes for v.5.7.0 have fixed Apple Watch crashes.

IMG_6457.jpg

Tags (1)
Jov
New Contributor

Thanks for this answer J_Lim. The app wasn't at the latest version, you are right. I had 5.6.1 installed still. But are you sure this fix the issue here ? I mean I haven't seen anything crashing it just stop working on the watch claiming that I had to log into the account or something to finally discover that I had lost all configured accounts in the authenticator on the phone. Now if you say that a background process crashes it might explain why I haven't seen it crashing. That said, i'm not trying to access the vault yet as the description of the patch says but just authenticating using the MFA push functionality from the watch to access the vault only once authenticated.

Anyway thanks for this. Will see with time if the issue is fixed or not 🙂
Tagg
Active Contributor

@J_Lim, that's the LastPass app. This thread is about the LastPass Authenticator app.
scottso
Active Contributor

Same thing happened to me recently. Even worse is that I couldn't restore from backup. Good to know that maybe it's my Apple Watch making things go haywire. I can avoid using it with Authenticator.

 

A Lastpass support rep told me that the backup only happens the first time you turn on the backup in settings. So only two of my accounts were backed up, since I turned on the backup when I only had two stored. Makes no sense. At. All. 

 

At the very least, if this is the way it works, Lastpass should set it up as a "back up now" button rather than a toggle that makes you think it's backing up regularly. Even an employee answered this incorrectly on a recent thread.