cancel
Showing results for 
Search instead for 
Did you mean: 
CANPENDC
New Contributor

Auto logout not working?

Hello, is there an auto-logout setting? I noticed that if I log in and do not use my session (aka leave my vault open in my browser) then I am not automatically logged off at all even after over 20h of inactivity. I did a PoC yesterday and logged in at 11am, use my vault once, then left the browser open but I did not use my vault again at all for 21h.... this morning I go to the same browser session and was able to query my vault, launch items from my vault, enter dashboard page, everything and was not asked to re-authenticate at all. The only time I was forced to re-authenticate was then i purposely clicked REFRESH on the browser. I have screenshots & timesteps of all my activity (even putting laptop to sleep several times). My guess is that that LastPass is relying on client-server activity to see if a cookie/token is valid; otherwise.... there is no control on the users end to check for account activity (inactivity).

10 REPLIES 10
Former Member
Not applicable

Re: Auto logout not working?

CANPENDC
New Contributor

Re: Auto logout not working?

Not really as that seems to be focused on the EXTENSION vs you logging in to the actual vault (which is what I did). I cannot use the extension as its blocked by policy.

Former Member
Not applicable

Re: Auto logout not working?

See if this works. Login to your vault. On the left click "Account Settings". Then, at the bottom of the popup window, click "Show Advanced Settings". Scroll down to "Website Auto-logoff" (under the Security heading). Click the dropdown box to change the value.

lastpass.jpg

CANPENDC
New Contributor

Re: Auto logout not working?

Thanks. I just updated it to 10mins from the 2 weeks original setting; however, this makes me wonder..... if the setting was 2 weeks then why it prompted me for a password after 23h when i clicked "refresh"? In theory, i was within the 2 weeks period. Odd......

CANPENDC
New Contributor

Re: Auto logout not working?

I have not touched (on purpose) by LastPass browser session since Friday afternoon until right now; its not logout AND I am able to query my vault. If I do refresh, I will be forced to sign in again. I think something here is broken. Does anyone know how I can reach out to developers?

AshC
GoTo Moderator

Re: Auto logout not working?

@CANPENDC  Do you happen to have any plugins or security settings that may be clearing out local cookies, which LastPass relies on to keep users signed in? 


Ash is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
CANPENDC
New Contributor

Re: Auto logout not working?

No plug ins at all; my browser is Chrome, and no particular settings. In fact, I think the cookies are working well as if I refresh.... it will force me to reauth; however, if I do not refresh, then i can continue using my vault.

 

Try this (using a browser with no lastpass plugin: 

1) Log on to your vault

2) Query your vault

3) DO NOT touch that browser/session/vault at all for 4h

4) After 4h, go back to the browser and query your vault (DO NOT CLICK REFRESH)

 

Are you automatically logged off?

CANPENDC
New Contributor

Re: Auto logout not working?

Dont know what happened overnight but its finally working! the autologoff setting in Advanced Settings finally took effect! (I set it up to 10 minutes several days ago and nothing). Thanks!

AshC
GoTo Moderator

Re: Auto logout not working?

Great!  Thanks for confirming the functionality is working as intended. 


Ash is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!