cancel
Showing results for 
Search instead for 
Did you mean: 
RogerS1
New Contributor

Can't use LastPass app on M1 Macbook, saving entries times out

I started a Last Pass as a trial with the object of going to Premium it worked, however it simply does not work for me.

I tried saving a password but it just times out and says its taking too long, I have tried this many times.

I am in the UK using a new M1 MacBook Pro with Safari and a fast internet connection. Any ideas how to fix this or should I just try an alternative.

Thanks

2 REPLIES 2
RachelO
LogMeIn Contributor

Re: Last Pass does not work for me

Hello,

 

Currently the LastPass Mac app isn't officially supported on Macs with the m1 chips, could you try uninstalling your current install of the LastPass Mac App (as well as the Safari extension), emptying trash, restarting your machine, and then reinstalling using the latest version here: https://lastpass.com/download to see if that works?

Just to be sure, here are the steps to be sure the extension is installed and enabled in Safari as well: https://support.logmeininc.com/lastpass/help/how-do-i-install-the-safari-app-extension-on-my-mac-lp0...




RachelO is a member of the LogMeIn Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudos!
RogerS1
New Contributor

Re: Last Pass does not work for me

Thanks, I tried this procedure and its now working.

I will keep using it to see