Showing results for 
Search instead for 
Did you mean: 
Robert Busch
Active Contributor

Re: LastPass App and Safari plugin on Mac don't work.

Hey I may have found a  solution!


I opened up the LastPass app and entered in my login information  and the icon began spinning.  I then immediately went to the menu bar and went to File Menu and did "Clear Cache."


At first it just timed out.  I did it again and I am now logged in using my lastPass App.


Screenshot 2023-05-22 at 8.22.47 PM.png


I suppose the cache was too full or corrupted or something.. who knows?  It worked!


Don't forget to give me a thumbs up if this worked for you!


New Contributor

Re: LastPass App and Safari plugin on Mac don't work.

You are correct that this works. I have seen this for weeks to be a "work around", but it really is not.


First, you will have to do this every time you try to use the app. That is not a working app.


Second, this will remove any changes that you have made while offline! So if you made updates, say goodbye to those. Poof!


Third, while this "gets you in" the app still will not sync while you use this work around (a continuing part of the bug is that the desktop app won't sync anymore), so if you make changes with the app having connected this way, those will not sync and if you make changes elsewhere (say on a mobile app) those will not sync with the desktop app, so although this "gets you in" the desktop app thus accessed is not actually syncing or working.


It has been months now since the desktop app has last worked, because of this bug. Although I am a paying customer (and my company and employees too) and have been for years, I think I'm about ready to switch to another password manager. Does anyone have a recommendation for how to migrate to another app like 1password or a recommendation for another password manager in general? This has become too difficult to work around and lastpass does not seem to fixing it. What should I use instead and how do I migrate?



Robert Busch
Active Contributor

Re: LastPass App and Safari plugin on Mac don't work.

I also had an issue where I had to login again and faced the same issue.  I did find another place in the community that said they were able to resolve the issue by finding and removing a corrupted "shared" password.  I reached out to LastPass and they identified a corrupted shared password.  I removed it and so far I am not facing the issue any more.  Crossing my fingers!


My main reason for using lastpass rather than the keychain is the ability to share passwords with my family.  I too have been very frustrated by this apparent bug.  Anyone know of another password keeper that allows you to share passwords?