Showing results for 
Search instead for 
Did you mean: 
New Contributor

Unable to charge Mastercard - Family plan (first time) - "Something went wrong"

Hi, I registered as a Family Manager and tried to pay using my supplementary Mastercard credit card. My father is the main cardholder. 

After clicking submit, it says "Processing...", then a pop-up message says:
"We're sorry, something went wrong. Please refresh the page and try again. For further assistance, please contact us."

I tried refreshing the page to try again but the same message pops up.
I tried updating the payment method using this Mastercard but the message says: "Unknown error. Please try again later." 

I called the bank that issued this card and they said there were no problems with my card. No outstanding, there is sufficient credit limit, charging in USD from overseas is allowed as well. The bank said that they didn't receive any requests to charge the card at all, even though I tried a few times. They suggested to try again the next day. I tried again the next day and the same messages popped up again. I tried in the morning, afternoon and night, and same message. 

Finally, I tried another card, my own VISA credit card. The transaction actually went through and it asked for authorization. I cancelled it so that I can try the MasterCard again. But the same message pops up when I tried to charge the MasterCard. 

The main differences between the 2 credit cards:

VISA (Main cardholder)
Bank: Standard Chartered Bank (Malaysia)
Expiry: Jul 2023

Mastercard (Supplementary cardholder)
Bank: CIMB Bank (Malaysia)
Expiry: May 2022

Both credit cards are fully paid every month, no outstanding, and has sufficient credit limit. I'm wondering if the Expiry date make the difference, since by the next renewal, which is Sep 2022, they won't be able to charge the same Mastercard, whereas the VISA can still be charged on the next renewal. 

Please help! Any help is appreciated! Thanks!

LogMeIn Contributor

Re: Unable to charge Mastercard - Family plan (first time) - "Something went wrong"

Hi @sonicssw2112,


You may encounter this error message if there is a technical issue with one of our payment processing systems or if a payment was declined during the checkout process of the purchase flow. If you encounter a technical issue or payment failure during the purchase flow, please contact LastPass Support by clicking Contact Support at the bottom of this article:


RachelO is a member of the LogMeIn Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudos!