cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Re: Failed to connect to the engine

I thought and hoped that my earlier posts would be my last ones regarding this infernal issue, but no.  It seems as though LogMeIn has accomplished one thing with regards to this problem:  They changed the verbage of the error message ever so slightly.

 

Why thank you, LogMeIn.  How very considerate.

 

It'd be nice if you, you know, fixed the problem as people who use Hamachi are typically using it in the fashion that YOU advertise they can use it... like being able to access their computers and files from anywhere in the world.  Well, anywhere provided that one of your Hamachi-connected machines didn't randomly stop the tunneling service for seemingly no single reason, as has happened with my desktop.

 

Seriously?!?  This bug completely undermines the usefulness of Hamachi.  How useful is Hamachi if it breaks on a random whim, taking access to the machine it decided to crash on with it?  Your program is useless to me if it does this, LogMeIn.  You had me fooled for awhile, because Hamachi was working great -- but then this bull**bleep** started happening again.  This is evidence, to me, that you never even addressed the problem in the first place.

 

Unacceptable.  If I could ditch Hamachi right now, I would in an instant.  I am so tired of relying on a piece of crap software that, sadly, can't be relied upon.  Ugh.

New Contributor

Re: Failed to connect to the engine

ITS HAPPENING TO EVERYONE 

Spoiler
they are nothing but freaking trolls and money hungry people!!!
Spoiler
DO NOT PAY FOR THIS SOFTWARE
Spoiler
THEY UPDATE TO THE NEW ONE TO MAKE U BUY THE PRODUCT ITS SIMPLE IF THEY DONT GET UR MONEY U DONT GET SUPPORT SO I WILL SUE THEM

 

New Contributor

Re: Failed to connect to the engine

I am getting the same error (win7 64bit) "Failed to connect to the engine". I've checked the service and it says the logmein Hamichi service is "started". So far I've tried:

 

*Stopping and restarting the service. (the service still says "started")

*Unistalling and reinstalling Hamichi (3 times with a freshly downloaded version)

*Setting the service to start manually and manually starting the service

*setting both the service and the UI to run as administrator

*Confirmed that Himachi is set to connections "allowed" in windows firewall

*Completely disabled the firewall

*Reboot, reboot and more reboot

 

Again, the service is "started" but when I try to start the UI I get the "failed to connect to engine" error. It worked fine a week ago. I've been using Hamichi on this computer for many months without a problem and I have made ZERO hardware changes. Other than windows updates no software changes either. 

 

PLEASE HELP!

 

 

New Contributor

Re: Failed to connect to the engine

I have been struggling with this now for 3 hours.  It happened once before and I just used the service tunnel to restart it and it worked again.  This time I can only get it to work in safe mode with networking.  Any ideas?  Same error, Cant connect to engine. 

New Contributor

Re: Failed to connect to the engine

this happened to me after my computer crashed and i reinstalled it. then i removed it and reinstalled it, still didn't work, then i did a bunch of configuration with my firewall... finally i gave up and unintalled, then reinstalled again. it started working again

New Contributor

Re: Failed to connect to the engine

after i pressed logmein hamachi 2.0 tunneling Engine the start button is'nt working

New Contributor

Re: Failed to connect to the engine

I have this problem as well.  This happens on two Windows 7 64bit SP1 systems and happens on clean installs of Windows.  Unfortunately, it only occurs once every 2-3 weeks.  Here's what I see:

 

On the laptop, the Hamachi client does not show my desktop as being online.

 

 

On the system that Hamachi failed to load (desktop):

 

On the Desktop, clicking Start -> All Programs -> LogMeIn Hamachi -> LogMeIn Hamachi, I get "Failed to connect to the engine."

 

Services shows "LogMeIn Hamachi 2.0 Tunneling Engine" as "Starting."  Bringing up the properties has all the service control options grayed out.  The path to executable: "C:\Program Files (x86)\LogMeIn Hamachi\hamachi-2.exe" -s" is in the process table with the matching command line (-s option).

 

Event Viewer has the following entry:

Log Name: System
Source: Service Control Manager
Date: 4/20/2011 7:49:59 AM
Event ID: 7022
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: Desktop
Description:
The LogMeIn Hamachi 2.0 Tunneling Engine service hung on starting.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
<EventID Qualifiers="49152">7022</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime="2011-04-20T11:49:59.550911000Z" />
<EventRecordID>13786</EventRecordID>
<Correlation />
<Execution ProcessID="724" ThreadID="728" />
<Channel>System</Channel>
<Computer>Desktop</Computer>
<Security />
</System>
<EventData>
<Data Name="param1">LogMeIn Hamachi 2.0 Tunneling Engine</Data>
</EventData>
</Event>

 

From Process Explorer, I created a full dump file of the ""C:\Program Files (x86)\LogMeIn Hamachi\hamachi-2.exe" -s" process and analyzed with WhoCrashed (donno what information if any can be determined from it):

 

Crash Dump Analysis
--------------------------------------------------------------------------------
Crash dump directory: C:\Windows\Minidump

On Thu 4/21/2011 1:17:49 AM GMT your computer crashed
crash dump file: C:\Windows\Minidump\hamachi-2.dmp
This was probably caused by the following module: hamachi_2.sys (hamachi_2+0xBB125)
Bugcheck code: 0x0 (0x0, 0x0, 0x0, 0x0)
Error: CUSTOM_ERROR
A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: hamachi_2.sys .
Google query: hamachi_2.sys CUSTOM_ERROR

 

Reboot fixes all.

 

Hope something helps because this problem is driving me nuts.

New Contributor

Re: Failed to connect to the engine

I found a solution to the stuck in "Starting" state here :

http://community.spiceworks.com/how_to/show/312

I used TaskMgr to find the PID for the LogMeIn Hamachi 2.0 Tunnelling engine,  which was stuck in Starting state. Then killed it with taskkill. Started it in the Services CP, and now Hamachi GUI connects to the engine again.

 

 

New Contributor

Re: Failed to connect to the engine

sal

 

New Contributor

Re: Failed to connect to the engine

This solution also worked for me.