cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Gateway Network

Greetings,

 

I have setup a Gateway Network via Hamachi but have a persistent problem on all my client computers.  On all 4 clients, all running Windows 10 Pro, the network comes up as Unidentified and gets marked public.  I have tried all the methods to change this that I know.   The server side looks great.

 

I have tried regedit changing the category under the network profile.  I have tried powershell setnetconnectionprofile method.  I have tried all idiot windows GUI bells and whistle.  I have tried setting the local security policy.  The only one that "works" at all is the powershell method but it is not persistent.  It is not practical to ask such of a user.

 

The clientside gateway network does not have a default gateway defined after creation.  I think windows automatically assigns such a network to public category.  I can interject a default gateway (which is just an experiment because I don't want local internet traffic routed thru the vpn to the office router) and boom, then network shows as private on the client side.  I can see the profile, change the name, etc.  I've tried the default gateway of the local subnet but that does not work.  This bastardized configuration however,  is not even persistent.  I have tried letting the DHCP server on the office router do the job, I have tried letting Hamachi act as the DHCP server, and both ways result in the same problem.

 

So seeing network resources  via SMB is not functional, which is one of the main purposes of the system, to enable printing at the other end. The testing work around is to enable network discovery on public networks and everything is functional, but this is obviously a non starter production solution for a mobile laptop who will undoubtedbly be on public wifi often and will end up with a comprimised firewall by default.

 

Is this the way a Hamachi Gateway ends up by design, as public on the client PCs?

 

Thanks in advance for any advice.