cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Hamachi + PfSense (firewall)

Hi,
    All contacts of my list in the Hamachi is with a blue ball. I am running it under a firewall. I need of a specific solution to it. I ever search in all topics and don't resolve this. Please, could someone give me some specific instructions? Thanks very much!

Abraão

7 REPLIES
New Contributor

Re: Hamachi + PfSense (firewall)

does anyone have a sollution????????

Please

New Contributor

Re: Hamachi + PfSense (firewall)

Hi,

 

¿Did you find a solution for this problem?

 

Thanks in advance

New Contributor

Re: Hamachi + PfSense (firewall)

I had the same issue and fixed it by enabling static ports in the NAT firewall of pfsense. See below link for more details on how:

 

https://forum.pfsense.org/index.php?topic=13669.0

 

Be careful and test out static ports before going into production (I'm assuming this is a work router and not just a home one) as I've read it will break other functionality such as VNC.

Tags (1)
New Contributor

Re: Hamachi + PfSense (firewall)

Thanks much for pointing out the solution! The pfSense wiki article is very clear and direct. Note that if you have more than one network set up (for example, a wireless card or additional net on OPT1), you'll need to decide if you need to enable Static-ports on their outbound traffic as well.

 

Active Contributor

Re: Hamachi + PfSense (firewall)

here the PF info:

https://doc.pfsense.org/index.php/Static_Port

Firewall/NAT/Outbound >> Outbound NAT Mode

 

Note: can't use destination of Ham IP 25.0.0.0/8 as the connection is doen WAN to WAN address (not with the Ham IP)

New Contributor

Re: Hamachi + PfSense (firewall)

Could you give me a step by step? I'm a beginner with pfsense, and the link you point to makes no sense to me. This is for home use.
New Contributor

Re: Hamachi + PfSense (firewall)

Hey MattHelm,

You need to go to firewall > nat > outbound nat

Once there, you need to change the mode to advanced or manual nat (I think default is auto nat, I prefer manual, when you get more proficient with pfsense you can choose solely manual).

Choose manual once and it will either ask if you want to create outbound nat rules or it will automatically convert for you. Switch back to adv and use that going forward (or stay on manual and know its pains/graces).

Find the wan to any rule and modify it. Go down to translation and turn on static port. Hit save.

Create an alias for your local machine ips that use Hamachi, then create another alias for 2 ports (57677-57678?) doesn't have to be any specific port, just something you will know and will be using later.

Create a nat rule that goes tcp/udp WAN ANY to LAN HAMACHI COMPUTER and specific the HAMACHI PORT in source and destination port sections.

On your Hamachi computer, go to the adv settings and specify the ports you made above.

It should go green after you restart the Hamachi engine.

Unfortunately I'm going from memory as I did this a long time ago and I'm on my phone so I cannot verify.