cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

Thank you, thank you.  This fixed my issue.  Took me a while to realize it was hamachi that was causing the problem as I had been using hamachi for years with no issues.  Wasn't until we installed an Alpha  AWUS036NH  long range wifi adapter that I started having problems.  THen once we realized hamachi, we couldn't figure out how to fix other than turn off hamachi.  of course that's not acceptable since we need hamachi for me to connect to my work machines from home.

 

i sure appreciate you posting this fix....

Active Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

Ehi everyone, the solution suggested here works for me as well, but I was trying to make it permanent maybe setting it in my router settings.

Unfortunately the interface isn't very explanatory to me.

Here is a screenshot

 

https://dl.dropbox.com/u/4064417/RouterRoutingInterface.jpg

 

How do I fill it?

 

Thank you very much

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

I do not know what to do. I had Hamachi to play on a minecraft server. I got bored of the server and hardly ever play on any other Hamachi servers so I decided to uninstall it. I restarted my computer, now it says there is a problem with my internet connection and my skype won't start either. Before I had restarted my computer, it said I was connected to the internet, but my browsers would not connect to the internet, and my skype was the same as it is now. Any help?

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?


ColdPetRat wrote:

Yep, I was right, it's a routing issue.  The fix is a little tricky, it's like this:

 

1. Run an elevated cmd.exe (press start, type cmd, press ctrl-shift-enter, approve UAC prompt).  Make sure cmd.exe window says "Administrator:" in the title bar.

 

2. Run "route print" and then in the first section "Interface List" find the leftmost number for the line that corresponds to the "Hamachi Network Interface."  For me this was 20.

 

3. Run "route delete 0.0.0.0 IF 20" (replace 20 with your number from step 2).

 

That's it.  Before I did this, I had a line in the "Persistent Routes" section that listed the hamachi interface handling 0.0.0.0 with default metric, even though the line in the "Active Routes" section listed the metric as 9256.  I'm not sure what all that means, but Hamachi still works fine after doing this (I'm not sure why it would need a catch-all 0.0.0.0 route anyway).


I sort of worked with your post, seeing as it was only a "temporary fix" and made a somewhat of a make-shift permenant fix. I have made two batch scripts: route.bat and execute.bat

 

Route.bat RUNS execute.bat with administrator priviledges.

Execute.bat simply runs your command in cmd.

 

Download my bat scripts and place them in your startup folder found in the start menu (typically located here: C:\Users\%user%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup).

 

Before you can use either script, you will need to right and edit both of them, i have placed in (parenthesis) where you will need to place your own info. "Execute.bat", you need to place your interface number that you found in ColdPetRat's post on step 2. "Route.bat" you will need to replace the user with a ENABLED administrator account on your windows machine, and also you will need to place the path to "execute.bat" as well. 

 

On the first run of "Route.bat", it will prompt you for the administrator account password. don't worry though, it only asks for it once, i haven't had it ask again after that one time.

 

This is a rugged, not so official solution, but i have tested it and it works, i hope it helps you Smiley Happy


Link to my scripts: http://dl.dropbox.com/u/39264764/hamachibats.zip

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

I have got up to the stage where I type in the password and for some reason it wont let me type anything ive tried running as adim and everything

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

When typing passwords in the command line, you don't see any letters or asterisks, but the password is still entered.

 

Just type it in and press enter. It should work even though the letters are invisible.

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

I also have a similiar issue. All of my programs were working fine until i downloaded Hamachi to run a Minecraft server for me and my friends. Right after installing Hamachi i tried to access Skype to tell my friends the network ID and password but unfortunately was NOT able to connect to Skype. I got the message 'Oops..." which is a message that tells you to restart Skype or try again. I contacted Skype about this issue and asked the staff over at Skype many questions trying to solve my problem. I assumed it was an issue with Skype because in the same day I installed Hamachi Skype released an update that i downloaded. It seems to me now that it was not an issue with Skype but maybe an issue where Hamachi is interfering with my Skype. Although it IS possible that it still is an issue with Skype, because i am running Windows 8 Skype which, as we all know, Windows 8 has some bugs. I am hoping either Skype, Hamachi, or I will find a way to solve this problem because i am becoming frustrated with both programs. Let us all hope the issue resolves itself.

 

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

I had the same problem and for a while I thought it was a virus, and downloaded like 5 virus protection programs, none of them could find anything. So eventually I started deleting Add-ons and then saw my hamachi was running though i thought i uninstalled it a while ago, once i got rid of it, my internet works perfectly and i dont have to keep reseting my wireless adapter. I thought it was a virus for a long time, but it was just logmein screwing with my adapter

 

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

thanks 

 

that worked for me 

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?


ColdPetRat wrote:

Yep, I was right, it's a routing issue.  The fix is a little tricky, it's like this:

 

1. Run an elevated cmd.exe (press start, type cmd, press ctrl-shift-enter, approve UAC prompt).  Make sure cmd.exe window says "Administrator:" in the title bar.

 

2. Run "route print" and then in the first section "Interface List" find the leftmost number for the line that corresponds to the "Hamachi Network Interface."  For me this was 20.

 

3. Run "route delete 0.0.0.0 IF 20" (replace 20 with your number from step 2).

 

That's it.  Before I did this, I had a line in the "Persistent Routes" section that listed the hamachi interface handling 0.0.0.0 with default metric, even though the line in the "Active Routes" section listed the metric as 9256.  I'm not sure what all that means, but Hamachi still works fine after doing this (I'm not sure why it would need a catch-all 0.0.0.0 route anyway).


Worked for me too.  Apparently still happneing all these years later.  I've been installing Win8 on all of my machines at home and at the office and have run into this a couple of times.  Now I know what to do.  Thanks for the good info!