cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?


MaryDB wrote:

Thank you, thank you.  This fixed my issue.  Took me a while to realize it was hamachi that was causing the problem as I had been using hamachi for years with no issues.  Wasn't until we installed an Alpha  AWUS036NH  long range wifi adapter that I started having problems.  THen once we realized hamachi, we couldn't figure out how to fix other than turn off hamachi.  of course that's not acceptable since we need hamachi for me to connect to my work machines from home.

 

i sure appreciate you posting this fix....


Yeah that's what happened to me.  I installed Hamachi and didn't reboot my Win 8 machine for quite a few days.  Once I did, the issue kicked in.   Immediately I was reversing changes I had made that day.  LOL 

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

I contacted Hamachi support. Here is the response I got:

(I haven't tried this method yet but it seems like it might work.)
I hope this helps all of you. This is so aggravating!

 

     

Hello,

 

Thank you for contacting LogMeIn.

 

 

After installing Hamachi you may encounter connectivity issues due to connection Metrics.  Windows uses Metrics to determine the order it will attempt to acquire internet access.  The Hamachi adapter may be auto assigned a lower Metric than the adapter that provides your internet connection.  You will need to manually assign the Metric to resolve.

To manually assign a Metric:

Windows XP
  1. Open the Control Panel.
  2. Go into Network Connections.
  3. Right Click on the Hamachi adapter, and click Properties.
  4. Highlight Internet Protocol (TCP/IP), and click the Properties button. In a 64bit OS, it will be listed as Internet Protocol Version 4 (TCP/IPv4).
  5. Now choose the Advanced button.
  6. At the bottom of this page, uncheck the box labeled Automatic Metric, and enter 9000 as the Interface Metric.
Windows Vista
  1. Open the Control Panel.
  2. Go into Network and Sharing Center.
  3. In the left pane, click Manage network connections.
  4. Right Click on the Hamachi adapter, and click Properties.
  5. Highlight Internet Protocol (TCP/IP), and click the Properties button. In a 64 bit OS, it will be listed as Internet Protocol Version 4 (TCP/IPv4).
  6. Now choose the Advanced button.
  7. At the bottom of this page, uncheck the box labeled Automatic Metric, and enter 9000 as the Interface Metric.
Windows 7
  1. Open the Control Panel.
  2. Click into Network and Internet > Network and Sharing Center.
  3. Click Change adapter settings on the left pane.
  4. Right-click on the Hamachi adapter, and click Properties.
  5. Click Internet Protocol (TCP/IP) to highlight it, and click Properties. In a 64-bit OS, it is listed as Internet Protocol Version 4 (TCP/IPv4).
  6. Click Advanced.
  7. At the bottom of this page, uncheck the Automatic metric option, and enter 9000 into the Interface metric field.

Performing the above steps will assign Hamachi a very high metric, making it the very last thing Windows use to attempt an internet connection.  If that does not resolve it, perform the same steps on the adapter you want your internet connection to be on, but assign it a 100 metric.

 

 

 

We have found that this solution typically resolves your specific issue. If you need further assistance, call us at 866-478-1805 to explore additional options.  Alternately, we have online resources available.

 

 

Thank you,

 

Mike Peaden | User Services Rep 

· · · LogMeIn

 

 

------ MY Question/Comment ------

 

Hi, [OS WIN-7] Whenever I attempt to connect to the internet (loading a webpage or running Skype or similar) they will not load. This is surely due to the Hamachi Network "Unidentified Network" that shows up on my computer at startup. I'm glad this is here when I need to use LogMeIn Hamachi, but when I am not using it, it is a real pain to have to go into the Network and Sharing Center and disable it. I have checked your forums but nothing has helped me thus far. Unidentified network still shows up in my list of networks.
If this can't fix, I'd rather just stop Hamachi from auto-running at startup. I have tried many methods to do this, none of which have worked. Please e-mail reply or call me if you have any questions.

 

 

 

     
 
New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

I did this then reset my router but not sure if this will permanently fix it
New Contributor

It doesn't work I was wrong the only fix that works for m...

It doesn't work I was wrong the only fix that works for me is to uninstall hamachi
New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

A simple way to do this is just merge both networks as one. It runs hamachi right into your internet.

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

Non of these things work for me. I uninstalled Hamachi thinking it would fix it but it didn't. When I tried to do the command I typed in route Route delete 0.0.0.0 masks 0.0 etc. and then it said the route deletion failed: elements not found.can someone please help me I am freaking out!
New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

Route delete 0.0.0.0 just it @@ man

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

I am in the exact position as you. I've tried every method out there to fix this problem

 

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

Everyone to fix this go to your task manager.

 

Then go to services and click services at the bottom right.

 

After that stop the following things.

Homegroup listener

Homegroup provider

Logitech Bluetooth Service

Logmein Hamachi Tunelling Engine

 

And thats it. The most important one is the Tunneling Engine you may be ok with only disableing that.

New Contributor

Re: Hamachi conflicts with internet - network adapter conflict?

I've had the same problem in the past. Can you connect using any other devices? What could be hapenning is something called Local Bridging. If you cannot connect using other devices, it is most likely the case.

Local Bridging is where your computer tells the router and Hamachi to make a little product called a Network Bridge. Local bridging is where this bridge tells the router that it is limited only to the bounds of the Local Network and it's connected Counterpart, the Hamachi Direct Tunnel - HDT.

Some computers do this on accident as a way of connecting itself using the router to the peer.

In my case, I was bridging a 1000Mb/s connection to a 130Mb/s connection but I was also disabling net access. The way I worked around it was simply disconnecting the bridge and losing that fake Gigabit internet speed.

Anyway, hope you can diagnose it using the clues we've provided.

 

~bb00