cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Hamachi doesn't work after sleep

I've set up two compters recently and both have had the same issue.  The only thing similar with the two is they are running Windows 8 Pro and the computers are on a domain. I've set it up to our office's hamachi network, and everything works fine until the computer is put to sleep. 

 

I've noticed that on boot - the system labels hamachi under the domain name and labels it as a Domain network.  Once slept, it "loses" something and becomes an unidentified network. 

 

With this information, this is the main issue:  Once slept, the computer is unable to access any of the network drives anymore.  I cannot get a ping on anything on the Hamachi network, and any mounted drive that was working before sleep does not anymore.

 

A simple reboot fixes the issue, but the computers generally aren't shut down (just logged off.)

35 REPLIES 35
New Contributor

Re: Hamachi doesn't work after sleep

I have the same issue though and hope someone can help us out.

 

My environment is a Lenovo laptop runing windows 8.1.  two identical laptops do the same thing.  I also tried a third computer, an Asus running Windows 8.1 - same problem.   A desktop running Windows 7 works just fine after resume from sleep.

 

I noticed that on reboot, the Ethernet adapter has a small change.  Before reboot, ipconfig /all reports an "Ethernet Adapter Ethernet", and E-WDS6.com for DNS suffix.  After sleep, the DNS suffic goes away, and the Ethernet Adapter reported is nw "Ethernet Adapater 2:.  The fact that the name changes, seems to be maybe related to the issue, but probably not.

 

After resuming from sleep, still get the green dots in hamachi, but no pings return

 

Here's a diff of the two outputs (the top one is after resume from sleep)

 

 

> Ethernet adapter Ethernet 2:
>
> Media State . . . . . . . . . . . : Media disconnected
> Connection-specific DNS Suffix . :
> Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller #2
> Physical Address. . . . . . . . . : 08-9E-01-F6-1A-A3
> DHCP Enabled. . . . . . . . . . . : Yes
> Autoconfiguration Enabled . . . . : Yes
>
29,37d37
< Ethernet adapter Ethernet:
<
< Media State . . . . . . . . . . . : Media disconnected
< Connection-specific DNS Suffix . : E-WDS6.COM
< Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
< Physical Address. . . . . . . . . : 08-9E-01-F6-1A-A3
< DHCP Enabled. . . . . . . . . . . : Yes
< Autoconfiguration Enabled . . . . : Yes
<

New Contributor

Re: Hamachi doesn't work after sleep

Asus laptop with Windows 8.1. Same problem.

fix this problem: manually restart service Hamachi.

New Contributor

Re: Hamachi doesn't work after sleep

I have the same issue. It would seem Hamachi has some issues running on Windows 8/8.1

 

Hopefully these issues can be resolved.

New Contributor

Re: Hamachi doesn't work after sleep

I've encountered this same problem as have a number of my users.   It seems related to Windows 8+ as i don't recall encountering it on Windows 7.

 

Is this a known issue?  If so, is it likely to be ireoned out?

 

All help appreciated 

 

 

Cheers

Retired LogMeIn Contributor

Re: Hamachi doesn't work after sleep

Yes, this is an issue we are aware of, and should have a fix out for it shortly.

 

Please PM me if you would like to try beta version now.

Sean Keough
Product Specialist, LogMeIn Support
New Contributor

Re: Hamachi doesn't work after sleep

I have two Win 7 64-bit laptops where we have encountered this problem.  Does the latest Hamachi update (2.2.0.130) address this issue for Windows 7 64-bit as well?

New Contributor

Re: Hamachi doesn't work after sleep

Same issue here with a Dell laptop and Windows 8.1.

 

After coming out of sleep mode Hamachi is not running and then fails to connect to the engine when you try to start it manually.

 

~eric

 

Active Contributor

Re: Hamachi doesn't work after sleep

same problem under windows7 ultimate 64bits.
I suggest you restart hamachi service. you can do that easily like this:

sc stop Hamachi2Svc
sc start Hamachi2Svc

New Contributor

Re: Hamachi doesn't work after sleep

Thanks skyrail.

 

That sounds like a workaround. I'll give it a try.

 

LogMeIn, will you be able to gix this? Running that command each and every time you come out of sleep mode should not be necessary.

 

~eric