cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Hamachi going offline in loops

Hi,
I have hamachi installed on my laptop with Windows 10 and very offten it will go offline in loops that last for hours. Sometimes it will connect and stay connected.
When it goes in loop it changes the statuses: offline, reconnecting, resolving, connected, probing, synchronising... There are more than 600 peers in the network, after the syncronising the ones that are online are going from red (relayed tunnel, blocked) to blue (relayed tunnel) and suddenly the hamachi is offline and the loop starts again.

 

Here is the part of the log that in my opinion shows the moment when hamachi goes offline:

 

02/06 06:07:02.934 [37428] tun: servicing [215-786-552] tunnel
02/06 06:07:02.939 [37428] tun: initiating CE
02/06 06:07:02.941 [37428] xhg: starting new exchange [I c3 3d14 0000]
02/06 06:07:02.943 [37428] xhg: sending ce 0d
02/06 06:07:02.947 [37428] tun: promoting new sa
02/06 06:07:02.952 [37428] xhg: new_sa_used, for completed exchange
02/06 06:07:02.960 [37428] xhg: accept
02/06 06:07:02.963 [37428] xhg: updated exchange [I c2 5678 9345]
02/06 06:07:02.968 [37428] xhg: ae_frame, auth 01
02/06 06:07:02.972 [37428] xhg: auth sig is valid
02/06 06:07:02.976 [37428] xhg: now have (old, cur) (8d41 8d51, 5678 9345)
02/06 06:07:02.978 [37428] xhg: completed
02/06 06:07:02.981 [37428] xhg: prodding the exchange ..
02/06 06:07:02.983 [37428] ses: io error, send, 0
02/06 06:07:02.986 [37428] ses: error 3, retryable yes
02/06 06:07:02.989 [37428] ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 17 ..
02/06 06:07:02.999 [37428] tun: deleting link, type 3, peer 173-824-571
02/06 06:07:03.001 [37428] dbg: link [0000020AC2F61D60] destroy
02/06 06:07:03.006 [37428] ses: set tunnel -> setup vpn peer
02/06 06:07:03.014 [37428] ses: [173-824-571], tunnel reset
02/06 06:07:03.018 [37428] tun: deleting link, type 3, peer 179-071-485
02/06 06:07:03.021 [37428] dbg: link [0000020AC2F61260] destroy
02/06 06:07:03.025 [37428] ses: set tunnel -> setup vpn peer
02/06 06:07:03.029 [37428] ses: [179-071-485], tunnel reset
02/06 06:07:03.032 [37428] tun: deleting link, type 3, peer 179-071-713

 

Please advise, thank you.

7 REPLIES 7
New Contributor

Re: Hamachi going offline in loops

I am having the same issue.  The only way I found to correct it is to remove Hamachi and re-install

Highlighted
LogMeIn Contributor

Re: Hamachi going offline in loops

@BrentF  @Pinc  I am sorry for the trouble there.

 

Are any of the affected machines under a Gateway Network Setting?  Typically if this is affected a group of machines on the same network, there may be an issue with the Network Adaptor.

New Contributor

Re: Hamachi going offline in loops

@AshC  No, the machines are on different networks in my case.

LogMeIn Contributor

Re: Hamachi going offline in loops

@Pinc   Would you be able to call into Customer Support the next time it happens, when you have someone at the affected PC to gather log files? 

New Contributor

Re: Hamachi going offline in loops

Thank you @AshC , I contacted the Customer Support and they escalated the ticket to Level 2 support. I am expecting an email from them.

New Contributor

Re: Hamachi going offline in loops


@Pinc wrote:

Hi,
I have hamachi installed on my laptop with Windows 10 and very offten it will go offline in loops that last for hours. Sometimes it will connect and stay connected.
When it goes in loop it changes the statuses: offline, reconnecting, resolving, connected, probing, synchronising... There are more than 600 peers in the network, after the syncronising the ones that are online are going from red (relayed tunnel, blocked) to blue (relayed tunnel) and suddenly the hamachi is offline and the loop starts again.

 

Here is the part of the log that in my opinion shows the moment when hamachi goes offline:

 

02/06 06:07:02.934 [37428] tun: servicing [215-786-552] tunnel
02/06 06:07:02.939 [37428] tun: initiating CE
02/06 06:07:02.941 [37428] xhg: starting new exchange [I c3 3d14 0000]
02/06 06:07:02.943 [37428] xhg: sending ce 0d
02/06 06:07:02.947 [37428] tun: promoting new sa
02/06 06:07:02.952 [37428] xhg: new_sa_used, for completed exchange
02/06 06:07:02.960 [37428] xhg: accept
02/06 06:07:02.963 [37428] xhg: updated exchange [I c2 5678 9345]
02/06 06:07:02.968 [37428] xhg: ae_frame, auth 01
02/06 06:07:02.972 [37428] xhg: auth sig is valid
02/06 06:07:02.976 [37428] xhg: now have (old, cur) (8d41 8d51, 5678 9345)
02/06 06:07:02.978 [37428] xhg: completed
02/06 06:07:02.981 [37428] xhg: prodding the exchange ..
02/06 06:07:02.983 [37428] ses: io error, send, 0
02/06 06:07:02.986 [37428] ses: error 3, retryable yes
02/06 06:07:02.989 [37428] ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 17 ..
02/06 06:07:02.999 [37428] tun: deleting link, type 3, peer 173-824-571
02/06 06:07:03.001 [37428] dbg: link [0000020AC2F61D60] destroy
02/06 06:07:03.006 [37428] ses: set tunnel -> setup vpn peer
02/06 06:07:03.014 [37428] ses: [173-824-571], tunnel reset
02/06 06:07:03.018 [37428] tun: deleting link, type 3, peer 179-071-485
02/06 06:07:03.021 [37428] dbg: link [0000020AC2F61260] destroy
02/06 06:07:03.025 [37428] ses: set tunnel -> setup vpn peer
02/06 06:07:03.029 [37428] ses: [179-071-485], tunnel reset
02/06 06:07:03.032 [37428] tun: deleting link, type 3, peer 179-071-713

 

Please advise, thank you.


I see only one solution to it..Remove himachi  setup completely and reinstall it.I don't see any other solution to it mybkexperience

New Contributor

Re: Hamachi going offline in loops

@charles2500 

It was done multiple times, on multiple machines, and it happens again. There are 5 machines affected, all of them on Windows 10, on a different locations, with different internet providers. The only thing in common is that all of them manage the same network, type hub-and-spoke.