cancel
Showing results for 
Search instead for 
Did you mean: 
bbiggs
Active Contributor

Hamachi randomly goes offline

I've loaded Hamachi (the latest version, 2.2.0.377) on a friend's Windows 7 computer. It's been on there for a while (a couple of years). I have been logging on recently to do some tech support for him and have noticed that occasionally when I go to connect, Hamachi is offline.

 

I can connect (via TeamViewer) to another computer in his network running Hamachi and then get to this computer as well to get Hamachi back online. The next day I typically have to do the same thing to get back in.

 

The Windows 7 machine is not rebooting; it remains logged on and working fine. I've left the Hamachi chat window on my side open for long periods of time and I can see his machine going offline, online, back offline, etc. at random times. He's not doing it manually. I've also uninstalled and reinstalled Hamachi to no avail.

 

Anyone ever seen anything like this? And have a fix?

 

Thanks,

Brian

6 REPLIES 6
kencoley
Active Contributor

Re: Hamachi randomly goes offline

Hi

 

We get this issue too, it happens when a connection becomes poor such as 3G or Satelite.WE have managed to write a script that fires it back up but really isnt viable long term.

 

This issue makes the product completely useless and there seems to be no response to the issue. We are moving to NeoRouter but are sad that what was a great solution is not viable anymore. 

 

 

Ken

bbiggs
Active Contributor

Re: Hamachi randomly goes offline

I still have no solution to this problem. It is still happening. Is anyone else experiencing this issue, other than the one person who commented? Is anyone from LogMeIn monitoring this forum and do you have any input?

 

-- Brian

AFNjohn
New Contributor

Re: Hamachi randomly goes offline

I'm seeing the same thing, and it looks to be the same scenario that Ken mentioned above - poor net con causing it to shut down.

 

Would want to see a response from LogMein on this one.

 

john

Colm_C
Retired LogMeIn Contributor

Re: Hamachi randomly goes offline

Hi Guys,

 

Are you still seeing this issue with the most up to date version? 

Which is Version 2.2.0.410, available here:

https://secure.logmein.com/hamachi.msi?_ga=1.165689657.665825872.1448362914

 

If you try uninstalling, reboot, then reinstaling with this link, does that help?

(make sure to reboot after the uninstall to clear out any trace of the app)

 

If not, can you try running the new diagnostic tool under 'help' and seeing if that points you towards what is causing the app to go offline!

 

Cheers,

Colm

 

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a star with the Kudos button.

Need more help? Search the knowledge base or contact Customer Care.
bluetech
New Contributor

Re: Hamachi randomly goes offline

I'm having the same problem in windows 8.1 & 10 pro, I've reinstalled hamachi multiple times but when I restart the server services fail to restart and manually I've to restart. Also, I'm facing Hamachi adapter crashing issue frequently and in network settings, I have to disable enable the hamachi adapter then again switch on the Hamachi.

bbiggs
Active Contributor

Re: Hamachi randomly goes offline

I stumbled across this old thread I had out here (and forgot about). Thought I'd post a quick note on the solution I've been using for a while. @kencoley  mentioned above that he had "managed to write a script" but it wasn't a long-term viable solution. Sounds like it's probably the same thing I'm doing. I'll provide the details of my solution. It feels like it's a long-term solution to me, so maybe it will help others out.

 

The solution is to create a Scheduled Task that uses the Hamachi command line utility to take Hamachi online and connect it to a specific network. It is a bare bones script. You can put a variety of variations on this to contain more robust error handling, connect to all of your networks, or whatever you want. This is a good starting point for a simple solution.

 

Create the script below and put it somewhere on your hard drive where you can run it (C:\, %USERPROFILE%\Downloads, or where you want to keep it).

 

hamachi_connect.cmd

:: Make sure this script starts in the Hamachi folder below
:: (in your Task Scheduler job)
:: cd C:\Program Files (x86)\LogMeIn Hamachi\x64

 

:: start Hamachi
hamachi-2.exe --cli login

 

:: Connect the desired network
hamachi-2.exe --cli go-online %1

 

Open up Task Scheduler in Windows 10 and create a Basic Task with the following options:

  • Name: Hamachi Connect
  • Task Trigger: Daily (or whatever frequency you prefer)
  • Start a program: Browse to the hamachi_connect.cmd file you created above
  • Add arguments (optional): Enter the Hamachi network you want to connect to (nnn-nnn-nnn). You can get this number by hovering over the Hamachi network name in the UI.
  • In the Start in (optional) box, enter the Hamachi application directory, which for most will probably be C:\Program Files (x86)\LogMeIn Hamachi\x64.
  • Check the Open Properties box to set a couple advanced features afterwards.
    • On the General tab, I check Run with highest privileges and Configure for Windows 10.
    • On the Settings tab, I check Run task as soon as possible after a scheduled start is missed

Thanks!