cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Hamachi won't connect (Mac)

Whenever I launch Hamachi it shows an IP address 0.0.0.0 and it says "connecting.." or "resolving..". This has been happening for awhile, it usually starts working eventually but lately I haven't been able to connect at all. I uninstalled and deleted all the config files and tried to reinstall it, but that didn't fix it. My computers firewall is currently turned off so that isn't getting in the way.

Here is the log file while trying to connect:

 

Spoiler
02.04 15:38:55.800 cfg: load()
02.04 15:38:55.812 cfg: [/Library/Application Support/LogMeIn Hamachi/config/h2-engine.cfg] is empty
02.04 15:38:55.829 cfg: cannot open [/Library/Application Support/LogMeIn Hamachi/config/h2-engine-override.cfg]
02.04 15:38:55.829 dbg: deploy_id '' parse failed
02.04 15:38:55.829 cfg: hkc set: [0] [0]
02.04 15:38:56.058 cfg: save()
02.04 15:38:56.059 cfg: hks: [1] [2048]
02.04 15:38:56.059 cfg: hkc: [1] [2048] [2048]
02.04 15:38:56.060 starting up ..
02.04 15:38:56.060 sys: version osx10.12.6-2.1.0.725
02.04 15:38:56.060 sys: os Darwin 16.7.0 Darwin Kernel Version 16.7.0: Thu Jan 11 22:59:40 PST 2018; root:xnu-3789.73.8~1/RELEASE_X86_64 x86_64
02.04 15:38:56.060 cfg: cannot open [/Library/Application Support/LogMeIn Hamachi/config/h2-engine.ini]
02.04 15:38:56.060 vpn: IPv6 support is: 3
02.04 15:38:56.060 vpn: auto-enable IPv6 support
02.04 15:38:56.061 ipc: 4 listening at /Library/Application Support/LogMeIn Hamachi/run/ipc.sock
02.04 15:38:56.061 sys: initializing vpn domains, vpn-reinstall = 0 ..
02.04 15:38:56.061 vpn: added [Hamachi] domain (not roaming)
02.04 15:38:56.061 dbg: setup_vpn_domain [Hamachi]
02.04 15:38:56.061 dbg: vpn_domain::config - [Hamachi]
02.04 15:38:56.061 vpn: switched [Hamachi] domain into L3 mode, 0.0.0.0/0.0.0.0
02.04 15:38:56.061 dbg: enable(Hamachi), locked: 0
02.04 15:38:56.061 vpn: domain [Hamachi] -> 'VPN_opening'
02.04 15:38:56.062 vpn: enabling [Hamachi] domain ..
02.04 15:38:56.062 vpn: on_set_tapdev(, 1) -> ok
02.04 15:38:56.062 tap: open(/dev/ham0) 5 2
02.04 15:38:56.062 vpn: domain [Hamachi] -> 'VPN_up'
02.04 15:38:56.062 dbg: setup_vpn_domain [Hamachi]
02.04 15:38:56.063 dbg: vpn_domain::config - [Hamachi]
02.04 15:38:56.063 vpn: domain [Hamachi] -> 'VPN_setting_up'
02.04 15:38:56.063 tap: config(ham0, 0.0.0.0, 0.0.0.0, [::/0])
02.04 15:38:56.063 tap: if_config() -> 1
02.04 15:38:56.063 vpn: tap config done, [ok]
02.04 15:38:56.063 vpn: domain [Hamachi] -> 'VPN_up'
02.04 15:38:56.064 vpn: added [Null] domain (not roaming)
02.04 15:38:56.064 dbg: setup_vpn_domain [Null]
02.04 15:38:56.064 dbg: vpn_domain::config - [Null]
02.04 15:38:56.064 ntm: netmon_add 0x100279430
02.04 15:38:56.065 pwr: power_mon_add 0x100279440
02.04 15:38:56.066 pwr: power state runloop thread started
02.04 15:38:56.070 02.04 15:38:56.070 ntm: starting run loop
pwr: starting run loop
02.04 15:38:56.092 ntm: got netmon event on main thread
02.04 15:38:56.098 ses: on_ip_change()
02.04 15:38:56.098 ses: on_rt_change()
02.04 15:38:57.682 ipc: 00702ae0 add client 1
02.04 15:38:57.882 cfg: save()
02.04 15:38:57.883 cfg: hks: [0] [2048]
02.04 15:38:57.883 cfg: hkc: [0] [2048] [2048]
02.04 15:38:58.032 ipc: 0040b820 add client 2
02.04 15:38:58.078 cfg: save()
02.04 15:38:58.079 cfg: hks: [0] [2048]
02.04 15:38:58.079 cfg: hkc: [0] [2048] [2048]
02.04 15:39:01.022 sys: connmgr_go_online, reconnect 0
02.04 15:39:01.078 ses: on_conn_state(connected, 0x0)
02.04 15:39:01.090 ses: select conn mode 'dns lb'
02.04 15:39:01.102 ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 4 ..
02.04 15:39:01.111 sys: go_online, reconnect 0
02.04 15:39:01.112 ses: resolving hamachi-dc.logmein-gateway.com ..
02.04 15:39:01.115 ses: resolving hamachi-list.5.logmein-gateway.com ..
02.04 15:39:01.166 ses: selected (69.25.247.116, 6909)
02.04 15:39:01.180 ses: selected 01 connection type
02.04 15:39:01.182 ses: resolving 69.25.247.116 ..
02.04 15:39:01.189 ses: connecting to 69.25.247.116:12975 ..
02.04 15:39:13.333 cfg: connection mask -> old: 7, new: 7
02.04 15:39:13.345 cfg: save()
02.04 15:39:13.360 cfg: hks: [0] [2048]
02.04 15:39:13.360 cfg: hkc: [0] [2048] [2048]
02.04 15:39:13.361 sys: connmgr_go_online, reconnect 1
02.04 15:39:53.292 ses: go_offline, keep_tunnels 0, login_on_relaunch 0, actual state 9 ..
02.04 15:39:54.176 sys: connmgr_go_online, reconnect 0
02.04 15:39:54.180 ses: on_conn_state(connected, 0x0)
02.04 15:39:54.180 ses: select conn mode 'dns lb'
02.04 15:39:54.181 ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 4 ..
02.04 15:39:54.182 sys: go_online, reconnect 0
02.04 15:39:54.183 ses: resolving hamachi-dc.logmein-gateway.com ..
02.04 15:39:54.185 ses: resolving hamachi-list.5.logmein-gateway.com ..
02.04 15:39:54.237 ses: selected (69.25.247.118, 6911)
02.04 15:39:54.238 ses: selected 01 connection type
02.04 15:39:54.239 ses: resolving 69.25.247.118 ..
02.04 15:39:54.241 ses: connecting to 69.25.247.118:12975 ..
02.04 15:39:59.050 ses: go_offline, keep_tunnels 0, login_on_relaunch 0, actual state 9 ..
02.04 15:40:01.033 sys: connmgr_go_online, reconnect 0
02.04 15:40:01.035 ses: on_conn_state(connected, 0x0)
02.04 15:40:01.035 ses: select conn mode 'dns lb'
02.04 15:40:01.035 ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 4 ..
02.04 15:40:01.037 sys: go_online, reconnect 0
02.04 15:40:01.038 ses: resolving hamachi-dc.logmein-gateway.com ..
02.04 15:40:01.039 ses: resolving hamachi-list.5.logmein-gateway.com ..
02.04 15:40:01.041 ses: selected (69.25.247.116, 6907)
02.04 15:40:01.042 ses: selected 01 connection type
02.04 15:40:01.043 ses: resolving 69.25.247.116 ..
02.04 15:40:01.044 ses: connecting to 69.25.247.116:12975 ..
02.04 15:40:56.060 
cfg: save()
02.04 15:40:56.065 cfg: hks: [0] [2048]
02.04 15:40:56.066 cfg: hkc: [0] [2048] [2048]
02.04 15:40:56.067 upd: fetching version info, [http://secure.logmein.com/versioncheck_hamachi.asp?os=osx&ver=2.1.0.725&lang=en&auto=yes] ..
02.04 15:41:00.159 upd: on_conn_state(connected, 0x0) - 2
02.04 15:41:00.225 upd: >> 241 bytes
02.04 15:41:00.226 upd: http transfer completed
02.04 15:41:00.227 upd: version [2.1.0.695]
02.04 15:41:00.227 upd: changes [http://help.logmein.com/SelfServiceReleaseNote?product=lmihamachi2]
02.04 15:41:00.227 upd: package [http://logmeincdn.http.internapcdn.net/logmeincdn/Hamachi_osx_210000695/LogMeInHamachi-2.1.0.695.dmg]
02.04 15:41:00.227 upd: details []
02.04 15:41:00.228 upd: not updating, have [2.1.0.725], avail [2.1.0.695]

I have tried to look up many different issues on the forums but nothing they said helped. Maybe I am just missing something so any help would be appreciated.

 

EDIT: I am sorry if I am missing any details that could help, this issue isn't happening on my computer. My friend is the only having trouble and he needed me to post a thread. If there are any questions I will ask him over text or discord and try to answer them the best I can.

Tags (3)