cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Re: Hamachi won't go automatically online

Has there been any update to fix this yet?

Highlighted
New Contributor

Re: Hamachi won't go automatically online

The last version 3.0.383.
Highlighted
Active Contributor

Re: Hamachi won't go automatically online

Versions 3.0.383 and 3.0.385 seem to work fine.  I'm having no issues with either one of them.

Highlighted
Active Contributor

Re: Hamachi won't go automatically online

Thank you guystooges.


I followed your procedure and downgraded to version 2.2.0.319. It's fine but I get RPV error and cannot ping another peer online in the same group, bothe associated to the same logmein account.
Nothing change after I reboot both device.
I guess it's a tunnel issue to a too old version.
Then I decided to follow the procedure again with version 
2.1.0.215.
It seems to work.

What is weird is hamachi kept all settings except auto-update turned to ON, then forced to create a new peer, get a new IP and join a network again.
The update to last version 2.2.0.519 was done automatically before hamachi go online and I create a new peer.
So I am stuck withe the last version.

Highlighted
New Contributor

Re: Hamachi won't go automatically online

Having the issue that Hamachi most of the time goes online automatically, but sometimes it doesn't after a reboot. So it is not really dependable.

 

Is there a solution to force Hamachi to go online automatically every time?

 

Or does that work only with a paid account?

 

Hamachi version: 2.2.0.526 on Win 7

Tags (1)
Highlighted
Active Contributor

Re: Hamachi won't go automatically online

I've had the same problem, and this fixed it. Thanks a lot, this worked great for me!

Highlighted
Active Contributor

Re: Hamachi won't go automatically online

Hi guys, 

I created a batch file that turns on hamachi and enables a network on startup. To get it to run subtletly on startup I created a shortcut to the file and changed the properties so it starts minimized.

Open notepad and paste in the following code.

 

cd C:\Program Files (x86)\LogMeIn Hamachi\x64
hamachi-2.exe --cli login
hamachi-2.exe --cli go-online <network ID>

NB:     1: The first line will vary depending on the location of your hamachi install

             2: Replace the "<network ID>" with the numerical identifier displayed when you hover over your Network in the Hamachi client. 

 

Save As and add ".cmd" to the file. Store it somehwere safe (I put it in the hamachi folder) and create a  shortcut.

Open start menu, type "run" and press enter.

Type "shell:startup" to open your startup folder and move the shortcut here. Finally right click on the shortcut, click properties and change the dropdown menu adjacent to "run" to Minimized.

Hope this helps, I'm not a coder so aplogies if this doesn't work for you. I built this out of some very basic how to guides and some trial and error with the hamachi-2.exe in CMD. Here's a link to the post that got me here Link to Post.

 

 

Highlighted
New Contributor

Re: Hamachi won't go automatically online

Hi ganeshowen,

 

I've run into a similar problem and tried using your batch file to enable a network on startup but am not having any success.

 

I've tried:

cd C:\Program Files (x86)\LogMeIn Hamachi\x64
hamachi-2.exe --cli login
hamachi-2.exe --cli go-online <XXX-XXX-XXX>

 

as well as

cd C:\Program Files (x86)\LogMeIn Hamachi\x64
hamachi-2.exe --cli login
hamachi-2.exe --cli go-online <XXXXXXXXX>

 

Running the file with the specified network does not work, nor does rebooting the computer and checking to see if it's online.  The only way for me to get online is to manually tell the network to go online.

 

Do you have any suggestions of what I else I could try or what I might be doing incorrectly?  I have double checked that I have the correct path to the hamachi-2.exe file.  The code itself is very simple, so I'm a bit at a loss.

 

As a test, should this work with the network offline and by just double-clicking the shortcut?  That does not bring me online either...

 

Thanks!

 

Hamachi v2.2.0.633 on Windows 10

Highlighted
New Contributor

Re: Hamachi won't go automatically online

FWIW since logmein dont seem to care about making Hamachi reliable

 

the problem you are having is the network id should not be wrapped in <> that is standard replace with value markers so what you really want is

 

cd C:\Program Files (x86)\LogMeIn Hamachi\x64
hamachi-2.exe --cli login
hamachi-2.exe --cli go-online XXX-XXX-XXX