cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Inconsistent IP address returned on Ping

Hi all,

A mysterious issue has just popped up and I can't figure it out.  I have been using a very simple Hamachi VPN for months. Just two computers, connected over the internet. WORK-PC is on the company network, my laptop is at home. Until a couple of days ago, this worked fine.  If I pinged WORK-PC from home, it would resolve to the Hamachi IP (25.82.xxx.xxx) .  If I pinged WORK-PC when connected to the office Wifi, it would resolve to WORK-PC's local IP on the office network (192.168.1.XX).  My home network uses 192.168.0.X.

 

Now, something weird is happening at home.  After starting the PC or restarting Hamachi, the first time I ping WORK-PC, it resolves to the Hamachi IP (25.82.xxx.xxx) and WORK-PC responds.  If I then ping WORK-PC again only a moment later, it resolves to WORK-PC's local IP address on the work network and cannot be reached.  So I have no communicate WORK-PC at all, unless I edit my hosts file or similar.

 

Here is the ping output...

 

Pinging WORK-PC [25.82.xxx.xxx] with 32 bytes of data:
Reply from 25.82.xxx.xxx: bytes=32 time=22ms TTL=128
...

Ping statistics for 25.82.xxx.xxx:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 20ms, Maximum = 47ms, Average = 27ms

 

C:\Users\xxxx>ping WORK-PC

Pinging WORK-PC [192.168.1.XX] with 32 bytes of data:
Request timed out....

Ping statistics for 192.168.1.XX:

Packets: Sent = 4, Received = 0, Lost = 4 (100% loss)

 

Has anyone got any ideas how to resolve this?  I'm completely stumped!

 

Thank you!

M