cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Microsoft Remote Desktop disconnects after a while

Good afternoon,

 

I have been working with Microsoft Remote Desktop and Himachi for years and untill everything worked fine. Now, we are working with the same machines, but the session of the Remote Desktop is disconeected after a while. We have tested in different equipment and we have the same issue. 

 

I have updated the Microsoft Remote Deskptop and Himichi in one of the equipment but there is no difference.

 

Could you give us some help?

 

Thank you!

2 REPLIES
Active Contributor

Re: Microsoft Remote Desktop disconnects after a while

I might be seeing a similar issue. When your connection disconnects do you get the 20 time reconnect screen where kt is trying to reconnect?
Active Contributor

Re: Microsoft Remote Desktop disconnects after a while

I think I got my disconnect problem fixed following these instructions: 

http://tomtalks.uk/2013/05/stop-logmein-hamachi-blocking-internet-connection/

 

For some reason the ipv4 interface metric for the Hamachi virtual adapter was set to automatic.  It should be 9000.

The setting is found under: The advanced properties Control Panel\Network and Internet\Network Connections\Hamachi .  I also disabled netbois for the Hamachi adater for good measure because netbois seems to add a dns of the remote machines local ip ( the non 25 one).  Systems seem to use that IP via a ping command.  It can also be seen via a Resolve-DnsName command via poershell untill netbios is disabled.