cancel
Showing results for 
Search instead for 
Did you mean: 
Active Contributor

Slow file tranfers between workgroup computers when Hamachi is running

Hello:

 

I run three Windows 10 computers in a workgroup over ethernet gigabiit LAN and each runs the Hamachi client.  I observe very slow file transfer speeds over the LAN when the Hamachi client is running (adapter enabled, client online, service running).  It looks as though whenever the Hiamachi client is running the transfer speeds are reduced to only 10 MBps on the gigabit LAN.  If I put the Hamachi client offline the speeds jump up to over 100 MBps, which is expected.  This behavior was not seen on our Windows XP computers (which we really miss by the way !!)

 

At this point I'm stumped.  One poster had the same issue but no one responded to his message:

/t5/Hamachi/How-to-fix-slow-LAN-transfer-speed/m-p/131578#M13076

 

Why does my workgroup speed default to the slower Hamachi 10/100 speed?  Is there a workaround?

 

One poster named Sean K made a statement that "if you are already on a LAN, the Hamachi connection is completely pointless". 

/t5/Hamachi/Is-1000-Mbps-possible/td-p/90403

(Sean, we run Hamachi over the LAN so we can access the computers from over the WAN).

 

I hope there is a fix.  The Hamachi client should run full time without interfering with and reducing the speed of the ethernet gigabit LAN. 

 

Thanks in advance for all responses.

 

Martin

 

 

 

 

4 REPLIES
Active Contributor

Re: Slow file tranfers between workgroup computers when Hamachi is running

Wow, what a sleepy support forum !  There is no activity here.  Waiting for a networking guru to chime in and help fix this problem !!

Did some digging around and found out that the Adapters and Bindings dialog is broken, inop, in Windows 10.  The big question is whether this is a bug in Windows 10 or the new normal.  See this example HERE.   Pretty obvious these adapters are out of the order I would prefer.  The adapter order can be moved up or down with the arrows on the right, but the changes don't persist and default back after closing the dialog.  Hamachi should definitely be number two in the list.

I've also tried the "Set-NetIPInterface -InterfaceAlias Hamachi -InterfaceMetric 20" command in Powershell, yet Hamachi pays no attention to this setting which should give my ethernet priority.  See http://tinyurl.com/qeettxy

Those with an eye for detail will notice that the latest update 2.2.0.406 installs the adapter with a metric of 9000, which is pointless if Windows 10 is not going to recognize it.

So far putting Hamachi offline is the only solution.  Kind of defeats the whole purpose of the VPN, ya think?

Active Contributor

Re: Slow file tranfers between workgroup computers when Hamachi is running

Goodbye Hamachi......

 

Hello NeoRouter !

 

just works

Active Contributor

Re: Slow file tranfers between workgroup computers when Hamachi is running

I still would like to get Hamachi working. I have this same slow-file-transfer issue. Actually share browsing in general.
Active Contributor

Re: Slow file tranfers between workgroup computers when Hamachi is running

netsh int tcp set global Timestamps