Showing results for 
Search instead for 
Did you mean: 
New Contributor

Windows 10 Pro - Hamachi wont open!

I guys, I actually tried to find some other posts about this problem, I have only seen one but it didn't looked like the same error.

Actually when I open my Hamachi it opens the Auto-Diagnostic window. I recently installed the Windows 10, I think this is the "final" version of Windows 10, because it doesn't say "build", just "Windows 10 Pro".

My computer is a bit old, it comes with Windows Vista, but then i got Windows 7, and now it was showing the Windows 10 icon, because microsoft was giving the windows 10, on the past it said that my computer would not be able to run Windows 10 but as I updated my drivers I can now run it and I installed it this morning :P.

But when I open Logmein Hamachi it opens that window, actually there is an error at Hamachi Service, but "Drivers" are fine and "Files and Folders" are fine too. My windows 10 is affecting other programs too, on Photoshop appears a message, and Minecraft crashes. Any ways, I will be sending a link with the images of the Hamachi Auto-Diagnostic window, as I'm Portuguese and as my hamachi is set to Portuguese the window is in Portuguese but there is the English version of that words between the ( ).


I want to solve the Hamachi problem but if there's a solution that solves the problems of the other programs I would like you guys to tell me... thanks for any help 🙂


LogMeIn Contributor

Re: Windows 10 Pro - Hamachi wont open!

Hi PirateGamer,


Hamachi has been released yesterday.

This version is designed to fix issues specifically resulting from upgrading to Windows 10.

Please update your Hamachi and let us know, if you still experience problems.



Zsolt is a member of the LogMeIn Community Care Team.
Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a star with the Kudos button.
Need more help? Search the knowledge base or contact Customer Care.

New Contributor

Re: Windows 10 Pro - Hamachi wont open!



Just had the same problem as you! 😉 Well, here's your answer!


To solve it:


1.Press Windows+R. (It will open a little window called ''Run)

2.Write -> services.msc

3.Once the window called ''Services'' is open, search for LogMeIn Hamachi Tunneling Engine

4.When you found it, right click on it and click on ''Start''

5.After it started and the Status is now Running, right click and click on ''Properties''

6.Go to Recovery

7.Change all the place where it's write ''Take No Action'' to ''Restart the service'' (So, you'll have to change First Failure, Seconde Failure and Subsequent Failures)

8.All done? All right! Start Hamachi normally, and go on for your activities! 😄


Have a nice day,


-Pitivier24, a simple Hamachi user 😛

New Contributor

Re: Windows 10 Pro - Hamachi wont open!

While im in services.msc, I go to rightclick logmeinhamachi tunneling engine to hit start, but im unable to click start. Every other option is usable except start. HELP!