cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

hamachi drivers for Windows 10 ARM

Hello, i'm looking for the last hamachi drivers for ARM computer compatible with win 10 x64 1903.

I have a tunnel RPV error because the network card is not installed.

I tryed to force the drivers installation in legacy mode. but win 10 ARM doesn't accept it (hamdrv, .cat. inf .sys). can you help me ? 

 

4 REPLIES 4
Active Contributor

Re: hamachi drivers for Windows 10 ARM

same error for me

 

windows 10

surface pro x

 

Active Contributor

Re: hamachi drivers for Windows 10 ARM

Got an answer from logmein support. Used 60minutes on phone to try and solve it. 

Then I had to hang up.

They figured out they dont have support for windows surface pro x with arm processor.

 

It may or may not be in development, that I couldt get hold of really.

 

Maybe someone from logmein can chime in and get this clear?

New Contributor

Re: hamachi drivers for Windows 10 ARM

ok thks, please keep me informed if there is any news from them.

it's annoying because I have the paid version ..

New Contributor

Re: hamachi drivers for Windows 10 ARM

Hello everyone,

 

I'm having the same issue as well with my new Surface Pro X (arm) computers I just got.

 

It appears that the hamachi tool installs without any issues & opens up with it stating that it connected to the mesh network however when I go and do a diagnosis test none of the drives are installed.

 

I've checked online and tried figuring out a solution but wasn't successful in finding anything that worked, i've tried;

  • uninstalling then reinstalling the hamachi tool (even gone as far as delete all the hamachi registries)
  • manually install the drivers through the device manager console - I get to a point that it won't accept the selected drivers and won't let me proceed to the next step in the installation wizard (so I'm guessing the drivers in the "programfiles" folder isn't compatible with the Surface Pro X hardware or something)
  • tried created a separate new network then reinstalling the hamachi tool with the new link
  • tried a different network type - I was trying to get the mesh network to work but then tried the gateway network and same results
  • i've also tried several recommendations to disable Windows Security Defender completely (antivirus, firewall, etc)
  • i've also tried disabling Microsoft Store app control - so that it would allow any 3rd party to run on the computer
  • I made sure that it wasn't in Windows S mode - I've even gone as far as reinstalled the entire windows 10 OS using a Windows 10 Pro installation disc.
  • i've also tried removing the bitlocker from the computer as well

With all this I was still not able to get it to work properly on the new Surface Pro X (Arm) computers I got, any recommendations or even a possible ETA on when there might be a solution or patch to fix this would be great so that I can see if I need to look for a different product to provide me with a vpn connection.

 

Thanks,