cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

himachi not working after reboot windows 10

2 of my cleints decided to upgrade their pc's to windows 10. After doing so they can no longer browse the remote server at their office location. If I uninstall himachi and reinstall it works but as soon as i reboot it goes back to being unable to ping or browe file shares. I was able to get ping working again by going onto the server and changing allowed connections in himachi details  to all from these 2 clients but i still cant browse. Everyone running windows 7, 8 or 8.1 can still browse the file shares without a problem. any ideas?

9 REPLIES
Highlighted
New Contributor

Re: himachi not working after reboot windows 10

I'm having exactly the same problem with my customers who have updated to windows 10.

 

Works fine when you install it. Doesn't work anymore after reboot. Have to remove and reinstall and then it works till the next reboot ...

New Contributor

Re: himachi not working after reboot windows 10

Hey Pfuhu,

 

i worked with support for 2 hours on the phone trying to narrow this down. No luck as of yet. Can you give me some info on your hardware? are these customers using wifi? the issues im having are all with wifi machines it seems. my desktop of course worked right away but it had himachi installed on it prior to the upgrade. the machines all having these issues did not have himachi installed prior to windows 10 upgrade. also using mikrotik routers at all effected locations.

New Contributor

Re: himachi not working after reboot windows 10

Same problem here. Clients are using WIFI on win10.
New Contributor

Re: himachi not working after reboot windows 10

Hello,

 

I just tried some things with the laptop of one customer.

 

Yes, they are using wifi. However I don't think it's related. What I tried:

 

uninstalled Hamachi again

disabled the wifi-hardware in the device manager

connected UTP-cable to the machine

reinstalled hamachi

Hamachi works

reboot

Hamachi doesn't work anymore

 

Hardware: laptop is a lenovo thinkpad T510

Wireless is a centrino Wireless-N 1000

NIC is Intel 82577LM gigabit network connection

Logmein was already installed before the upgrade

 

Clients are connected to multiple hamachi-networks.

One of the clients gives error towards a windows10-device: 'peer changed its key'

I don't know if this is related ...

 

New Contributor

Re: himachi not working after reboot windows 10

hey pfuhu,

 

I also had this error. i found that by going to the server or machine it is trying to connect to and hitting the update key feature on the details section of the connecting computer removed this error. that allowed me to ping the machine again but i still could not browse files.

New Contributor

Re: himachi not working after reboot windows 10

also my desktop which is also running windows 10 does not have these issues. its hard wired not wireless and it had himachi installed prior to the upgrade. all the machines i am having issues with seem to be wireless and did not have himachi installed prior to windows 10 upgrade.

New Contributor

Re: himachi not working after reboot windows 10

How exactly do you update the key? What button do you click and where is it located?

 

(perhaps has nothing to do with the problem: Hamachi-network I am using is a 'gateway'-one ...

New Contributor

Re: himachi not working after reboot windows 10

on the machine you are trying to connect to not from you need to right click the computer having the issue and go to details. since the peer key has changed it should probably have a red circle as opposed to a green inside either summary or settings there will be the error message which you can click and hit update key. that should change it back to allowing the connection. that will restore your ping but i cant for the life of me browse from a wireless windows 10 machine and see files and folders. 

 

Active Contributor

Re: himachi not working after reboot windows 10

I'm having this problem as well. Following a reboot, I have to do a complete uninstall, including the user settings, then reinstall and re-attach to my network. As i had email confirmation turned on, this always failed to connect to the licence server. At least i was able to resolve that problem by turning off the email confirmation option...

but if anyone has a quicker way to overcome this, i'm all ears!

K