cancel
Showing results for 
Search instead for 
Did you mean: 
Active Contributor

win 10 remote desktop connection kills hamachi on client machine

I have been suffering with this issue for some time now and im finally asking for some help. I have 2.2.0.633 version of hamchi. Any time i RDP using the remote desktop connection program built into my win 10 laptop, as soon as i disconnect the session, the hamchi tunnel is killed on the client machine, making it impossible for me to remotely connect again unless someone physically bounces the hamachi app for me.

 

the server address set in hamchi is std.hamachi.logmein.com with port 22

 

i had to set it to port 22 because i couldnt connect at school because they port block the hamachi default port. 22 was the first number that poped into my head.

anyway, none the less, i still cant use RDP because it kills the connection.

 

thanks

4 REPLIES 4
New Contributor

Re: win 10 remote desktop connection kills hamachi on client machine

I have had the same problem since I installed WIN 10pro 64 on this PC that previously had WIN 7. With WIN 7 pro 64 everything worked well, as soon as I try to connect with Remote Desktop the hamachi connection is disconnected. Help me

 

Thanks

Active Contributor

Re: win 10 remote desktop connection kills hamachi on client machine

I have searched everywhere for a solution and nothing. im still waiting for logmein to answer back. I feel like these forums are a lost and abandend group...

i hope we can get this solved soonSmiley Happy

Active Contributor

Re: win 10 remote desktop connection kills hamachi on client machine

Hello Matt,

Luckily we actually do have a workaround for this! Sadly it's only a workaround and not a fix. This happens because of the way RDP is coded. RDP essentially creates it's own environment for you to work in, so when RDP closes, it's also closing out the windows environment it created. And since you're on Hamachi free, Hamachi does not run as a service that automatically turns back on. 

The workaround we do have to workaround this issue is a .bat file that closes RDP without closing Hamachi. Please follow the instructions below to create the .bat and run it whenever you want to close RDP.


1.- Create the text file "KeepMeIn.bat" containing:
@echo off
set /p pass=Enter password(for rdp remote pc):
for /f "tokens=3 delims= " %%a in ('qwinsta^| findstr "Act"') do set SessionID=%%a
tscon %SessionID% /dest:console /password:%pass% && Rundll32.exe User32.dll,LockWorkStation

2.- Place the file in "C:\Program Files (x86)" or equivalent
3.- Right click on "KeepMeIn.bat" --> Send to --> Desktop (Create a shortcut) or equivalent
4.- Right click over the shortcut --> Properties --> Advanced Options --> Run as administrator

Instead of using the "X" to close the session or Windows --> Disconnect , use the shortcut. It redirects the GUI to the console and keeps it open allowing Hamachi to keep connected.

New Contributor

Re: win 10 remote desktop connection kills hamachi on client machine

hi,

 

we have paid version of hamachi and some users experiencing the same when using RDP over hamachi.

 

once they connect to RDP hamachi goes south and can't ping the server, rdp stalls or becomes very slow.

 

personally I don't experience the same.  very good.   They have upgraded to win10 1909 which I've been using since Nov 19 so fingers crossed.

 

n.b. once they installed 1909 updated hamachi had to be reinstalled.