cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor

Unattended Session Stuck on "Waiting for device to connect"

Hi there,

 

I'm coming from the old GoToAssist desktop client and trying out the RescueAssist browser version. However, I have a few unattended computers that don't seem to connect in RescueAssist even though they connect fine in GoToAssist. After I start the unattended session, the page just sits on "Waiting for device to connect..." and doesn't do anything at all. The installed version on the client side is already up to date.

 

I have already tried multiple browsers (Safari, Chrome, Firefox) and multiple computers (Mac and Windows).

 

Is this a known issue and can I provide any sort of logs to better assist in troubleshooting this?

 

EDIT: I did find a log entry that may indicate the problem:

2019-01-07 09:53:19.250 d: [g2ax_system_customer] <ECDynamicPoolWorkerThread(Callback)(0)> >>> CLauncherCustomerPluginBase::rpcEvent()
2019-01-07 09:53:19.250 i: [g2ax_system_customer] <ECDynamicPoolWorkerThread(Callback)(0)> RescueAssist - DownloadDir: C:\Windows\TEMP\
2019-01-07 09:53:19.250 i: [g2ax_system_customer] <ECDynamicPoolWorkerThread(Callback)(0)> RescueAssist - DownloadPathWithFileName: C:\Windows\TEMP\RescueAssist.exe
2019-01-07 09:53:19.250 i: [g2ax_system_customer] <ECDynamicPoolWorkerThread(Callback)(0)> RescueAssist - DownloadUrl: https://console.gotoassist.com/applet/download?pincode={redacted}&platform=win
2019-01-07 09:53:19.562 E: [g2ax_system_customer] <ECDynamicPoolWorkerThread(Callback)(0)> WinHttpHttpDownloader::download() - Download failed, Error:2001
2019-01-07 09:53:19.562 E: [g2ax_system_customer] <ECDynamicPoolWorkerThread(Callback)(0)> RescueAssist - Download failed with error code: 28466373222991825
2019-01-07 09:53:19.562 d: [g2ax_system_customer] <ECDynamicPoolWorkerThread(Callback)(0)> <<< CLauncherCustomerPluginBase::rpcEvent()

I did redact the session ID just for security.

 

Thanks,

Jared

1 ACCEPTED SOLUTION

Accepted Solutions
LogMeIn Contributor

Re: Unattended Session Stuck on "Waiting for device to connect"

Hi Jared,

 

My apologies for the issue you're experiencing. We recently stopped support for TLS 1.0 and 1.1 which can impact connectivity to certain Unattended Devices.

 

Could you please confirm that TLS 1.2 is enabled on these devices by following the steps outlined here


If this does not resolve the issue please let us know.

Chris Handley
Product Manager

2 REPLIES
LogMeIn Contributor

Re: Unattended Session Stuck on "Waiting for device to connect"

Hi Jared,

 

My apologies for the issue you're experiencing. We recently stopped support for TLS 1.0 and 1.1 which can impact connectivity to certain Unattended Devices.

 

Could you please confirm that TLS 1.2 is enabled on these devices by following the steps outlined here


If this does not resolve the issue please let us know.

Chris Handley
Product Manager

New Contributor

Re: Unattended Session Stuck on "Waiting for device to connect"

Thanks! This resolved the issue. I only had to follow the first two steps.