cancel
Showing results for 
Search instead for 
Did you mean: 
Active Contributor

How do I prevent the Country Code from being included when the phone number is autofilled?

I'm constantly running into an issue with the phone number autofill.  It automatically includes the country code regardless of if it is requested or not, and every site I come across seems to reject the phone number because of it.  If anyone knows how I can turn that off I would be greatful.

9 REPLIES 9
LogMeIn Contributor

Re: How do I prevent the Country Code from being included when the phone number is autofilled?

Hello,

 

Could you edit the entry in your Vault to make sure the country code isn't included in the Phone number field? Here's how to edit an entry in case you aren't sure how to: https://support.logmeininc.com/lastpass/help/how-do-i-prevent-lastpass-from-filling-erroneous-form-f...




RachelO is a member of the LogMeIn Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudos!
Active Contributor

Re: How do I prevent the Country Code from being included when the phone number is autofilled?

If the country code was included in the phone number of course I would remove it.  It however is NOT included.  The only thing that is included is the area code, the prefix, and the number.  The country code is almost never included within the USA.

LogMeIn Contributor

Re: How do I prevent the Country Code from being included when the phone number is autofilled?

Thanks for the information. To be sure there aren't any other Autofill services enabled which may be entering that country code, could you also double check that autofill is turned off in your browser settings?

 

Another troubleshooting step would be to delete the phone number entry and re-add it manually to make sure a country code field isn't being saved using the Save All Entered Data option:

  1. Delete your Vault entry with the phone number associated with it (instructions here).
  2. Add your site back manually by doing the following:
    • Navigate to your desired site or a site with a phone number field that usually inserts the country code when not wanted
    • Enter your phone number, but do not log in or submit the form field data on the page.
    • Click the browser LastPass icon, then go to Add item > Save All Entered Data at the bottom of the menu.
      (Tip: For Internet Explorer users, click the active LastPass icon , then go to Tools > Save All Entered Data.)
    • All captured fields are displayed. If desired, enter more information and specify your desired settings for the item or delete the country code field if present.
    • Click Save when finished and reload the page to test.

If you are still encountering this issue after trying these steps, this looks like it may be a bug we haven't yet encountered. So that our team can get more details and hopefully resolve the issue could you submit a bug report following the steps on this page? https://support.logmeininc.com/lastpass/help/how-do-i-report-a-bug-to-lastpass




RachelO is a member of the LogMeIn Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudos!
Active Contributor

Re: How do I prevent the Country Code from being included when the phone number is autofilled?

Do you even know how the product works?  The addresses and phone numbers are NOT site specific.  Further, they were manually entered to begin with, and I never included the country code.  Even more to the point, the country code should not be entered by default.  It should be an optional choice which the users should turn on.

 

There is nothing wrong with the entry that deleting it and recreating it will fix.  There is nothing that I did wrong that deleting the entry and recreating it will fix.  The entirety of the fault lies in the changes that have been made in updates which have started to add "country codes" which were not asked to be added or even entered in to begin with.

 

Next time, before you go reading from a script, actually go and use the product in question and realize that the issue has nothing to do with what your script says.  It has everything to do with the fact that your program is adding a country code when it should not be doing so.  This is not a bug, this is a design decision.  A bug would be if there was actually a way to choose whether to include the country code or not, and that choice being ignored, or if the wrong country code was being added.  This is a bad design.

LogMeIn Contributor

Re: How do I prevent the Country Code from being included when the phone number is autofilled?

Sorry for the frustration. I'm not able to reproduce this same issue when testing on my machines--I've added an Address item type to the Vault, and when adding the Phone Number field to this new Address item type the "Country" field is required to present the correct phone number format (3 digits-3 digits-4 digits for the United States, for example) but after saving this Address item entry in to the Vault, when entering this saved information in to websites with a Phone Number field, the country code is not automatically inserted on to the page in any of my tests.

 

Since I'm not able to reproduce the issue that you're experiencing on multiple browsers or websites, that is why I recommend submitting a bug report to our support team to be sure there isn't a bug that you may be experiencing or to see if they can resolve this issue or forward it along to our development team so they can be made aware that this is happening and remove this in future updates to LastPass.




RachelO is a member of the LogMeIn Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudos!
Active Contributor

Re: How do I prevent the Country Code from being included when the phone number is autofilled?

You forgot multiple devices. 

 

This is not a bug.  There are several other people who have previously made mention of this exact issue.  There is no place for a country code to be entered by the user as you yourself pointed out.  The only place that it can come from is the selection of the country, which as you also pointed out is required for the entry of the phone number.  Further the idea of it being a bug rather than by design is the simple fact that it is the country code being added, not a random or consistent number.  Further, these are occurring on newly created Address entries within LastPass, not ones which were created from an entry a person made on a website, so there is no way a hidden country code entry could be added other than by design.

New Contributor

Re: How do I prevent the Country Code from being included when the phone number is autofilled?

I'm experiencing the exact same bug. It's extremely annoying, and there seems to be nothing I can do to avoid it.  My area code is +47, and every time I autofill my address the phone number comes up with 47 as the first two digits.

 

I'm sick of this now, and I'm looking for a replacement for LastPass. However, I'm hoping it can be fixed as I don't really want to migrate. If you can't fix it, at least allow us to enter a phone number without an area code. That would work for most domestic forms that rarely require an area code. 

LogMeIn Contributor

Re: How do I prevent the Country Code from being included when the phone number is autofilled?

Hello @smack332 

 

Thanks for the info. While we aren't able to reproduce the issue in our tests, our developers would like to gather more information to further investigate and hopefully resolve this issue. So that we can gather more details and try to reproduce the issue once we have some more information about your setup, could you submit a report to our team by following the steps outlined here? https://support.logmeininc.com/lastpass/help/how-do-i-report-a-bug-to-lastpass




RachelO is a member of the LogMeIn Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudos!
Active Contributor

Re: How do I prevent the Country Code from being included when the phone number is autofilled?

It is quite obvious to anyone who has used your product, that you are not actually using it on real websites.  It does this every time.  Stop using it in your controlled conditions.  Go to random websites and start using it.