cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor

default form fill not updating - uses old data and passwords

I recently got replacement credit cards with new card numbers. After entering this info into lastpass i can fill in forms just fine if a select the card of interest. BUT if i use the default form fill option (i use a keyboard shortcut for this) the old credit card info is entered rather than the current card info! This is still the case even though the updated card numbers, cvv codes etc were entered months ago. I have tried logging out and logging in again to the lastpass extension, and i've tried restarting my web browser (chrome), but none of that has helped at all.

I tried to work around this issue by making a new credit card entry, but after doing that, the default form fill setting (account option > extension preferences > general > form fill > default form fill) does not even show the new card entry. I can swicth between old card entries, but then the filled information is old informaton for these entries that was changed months ago!! Any help, would be greatly appreciated.
6 REPLIES 6
Highlighted
New Contributor

Re: default form fill not updating - uses old data and passw

I have the same problem. Here are the steps I take to reproduce the probelm.

-add a new Address item in the vault
-click the lastpass extension icon in chrome toolbar
-click my account email (last option)
-click extension preferences
-in the "Form Fill" section, there is a drop-down menu "Default Form Fill"
-that list contains old entries that I don't even have in my vault, it does not contain the newly added Address item, and it also lists "0" as one of the options
Highlighted
New Contributor

Re: default form fill not updating - uses old data and passw

Has there been a solution to this? I’ve had the same issue for almost a year. Key point is utilizing the hot key to fill in the default form fill
Highlighted
New Contributor

Re: default form fill not updating - uses old data and passw

I also have this same issue.

I tried closing and re-opening Chrome, as well as reinstalling the extension. I'm thinking maybe if I delete the Lastpass extension folder it might reset itself.

Lastpass seems to be working with some kind of old data for the default form fill section within the extension preferences, seeing as the data in the default form fill drop-down menu remains unaffected regardless of what is changed below:

- If I add a new address, it doesn't show up in the default form fill drop-down menu.
- If I change an existing address shown in the drop-down menu, and try to fill it on a webpage, it still fills in the old data, even though it's been changed.
- If I change the name of an existing address, it doesn't show the new name in the drop-down menu, just the old one.

This feature used to work fine. I used it a lot in late 2016/2017.

Please help! 🙂
Highlighted
New Contributor

Re: default form fill not updating - uses old data and passw

Just a quick update:

I've tried 5 or 6 different form filling extensions for Chrome and none of them do what I want them to do the same way that Lastpass does.

I don't know if there even IS an extension that will do what I want.

I want to fill all applicable forms on the current page using a hotkey combo like Alt+Z.

Does anyone know of an extension that does this?

Thanks!
Highlighted
New Contributor

Re: default form fill not updating - uses old data and passw

Ok, so I found something that actually works - Chrome's built-in form filler! There isn't a keyboard shortcut option, but it doesn't actually matter, because it's basically just as fast.

All you do is go to settings and click on Autofill. Then, click Addresses & More. Set up your addresses and turn on "save and fill addresses" at the top.

Now, when you click in an open field on a web page, it will give you a drop down menu with your addresses. Then, you just click the address you want to use, and that's it. It will automatically detect all the forms on the page and fill them in for you. I've only come across a few pages where it hasn't worked, and that's because the site owners have done that deliberately to counteract bots and automated software.
Highlighted
New Contributor

Re: default form fill not updating - uses old data and passwords

I am having the same problem. I have sent a message to support. Will update here when they give me a sollution