Showing results for 
Search instead for 
Did you mean: 
New Contributor

GoToOpener always fails the download the first time

When I host a meeting  on my older MacBook Pro with High Sierra, GoToOpener invariably fails to launch the first time. It always works, thank God, the second time and I have almost got used to this, alhough I used to panic at first.  I get the warning that the download failed and then when I relaunch it, it works all right.


I hope this isssue can be solved, either on my computer, if possible, or on GoToMeeting's side.


Kind regards,


Piero Mattirolo

GoTo Manager

Re: GoToOpener always fails the download the first time

Hello Piero,

Have you tried performing a full uninstall of the GoTo Launcher and GoToMeeting application on the problem Macintosh?

Do you see the same error message in all web browsers there?

Ash is a member of the LastPass Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
New Contributor

Re: GoToOpener always fails the download the first time

Hello Ash, I apologize for getting back only now.   It seems so far that by uninstalling and re-installing the app the problem has disappeared - till the next update, I fear.  It would be useful to get an update reminder when a new release is available.  In fact, it is not quite clear to me what happens when I install the GTM app.  A new mini-app (gotodownloader) seems to be downloaded each time I start or join a conference, so what is the benefit from having an app installed anyway?  I tried launching a new meeting with the app uninstalled and didn't see any issue.