cancel
Showing results for 
Search instead for 
Did you mean: 
StephanF
New Contributor

Run Hamachi on Raspberry OS Bookworm

Hi there,

I run about 200 instances of Hamachi on raspberry pi zero WH's. Now its time to update the software to Raspberry OS Bookworm so I can add some camera features.
When I to install hamachi (https://www.vpn.net/installers/logmein-hamachi_2.1.0.203-1_armhf.deb) and try to start it I get this:

~ $ sudo hamachi
Illegal instruction

I just updated and upgraded the newly backed image. What is it that goes wrong? And is there a way to fix it?

On the old image I used the armEL version but that also seems not to work anymore and does not have my preference.

5 REPLIES 5
GlennD
GoTo Manager

Re: Run Hamachi on Raspberry OS Bookworm

Hi @StephanF, welcome to the community.

 

We are looking into this and will post an update once we have news.

 

Glenn is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!.

Free new user and admin training
StephanF
New Contributor

Re: Run Hamachi on Raspberry OS Bookworm

Hi Glenn,

That would be great! I'm depending on your remote controll solution at the moment 🙂

 

 

GlennD
GoTo Manager

Re: Run Hamachi on Raspberry OS Bookworm

@StephanF We are testing some new builds with Raspbian 12 Bookworm currently, once we have a stable release I will post an update.

 

Glenn is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!.

Free new user and admin training
GlennD
GoTo Manager

Re: Run Hamachi on Raspberry OS Bookworm

@StephanF,  after a lot of testing we have a path to supporting the new Bookworm OS, however we will not be able to implement it until next year, 2024. For now our recommendation is to delay upgrading to Bookworm if possible.

 

Glenn is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!.

Free new user and admin training
stevesi
New Member

Re: Run Hamachi on Raspberry OS Bookworm

I've got a number of new installations and can no longer install Hamachi using older distro's as Bookworm is now minimum requirement for our hardware.

 

Do you have any workarounds while you work on a new installer package?

 

SteveSI