Showing results for 
Search instead for 
Did you mean: 
Active Contributor

Azure Conditional Access blocking LastPass on iPhone

Hi All

We use Lastpass Enterprise, using federated Azure login.  All works fine on PC's.  Conditional Access in Azure is setup to ensure that users can only log into the SSO resources ( 250+) from InTune managed devices.  It requires that authentication requests from from Chrome or Edge. 
Lastpass has its own browser and does not send the authentication request via Edge or Chrome so therefore its getting blocked and users cannot log in. 
LastPass say that they are aware of this.  its not a fault with their product its more of a change they need to make to enable their product to work with AAD Conditional Access rules.  
Has anyone found a way round this?

Tags (1)
GoTo Contributor

I am sure we will have pleasant news and a Christmas present for you this year.

Active Contributor

Hey Glenn and LastPass team, any news on this so far?



GoTo Manager



I apologize for the frustration, I know you have been dealing with this issue for some time. I have checked in with the team and they are still working on this issue. We are working with a few customers directly and testing a beta, but it is a manual process for now so it is not open for everyone to try. We should have more news in the new year.


Glenn is a member of the GoTo Community Care Team.

Was your question answered? Please mark it as an Accepted Solution.
Was a post helpful or informative? Give it a Kudo!
Active Contributor

Dear @GlennD 

As the customer that reported this issue, i would very much like to be ( and expect to be) part of the beta testing.  

please let me know how i can get in on the testing process.  

Many thanks

Owen John


Active Contributor

Still no resolution to this.  SHAME ON LASTPASS .  issue logged in 2020!!!!


This is ridiculous and TERRIBLE customer support

Active Contributor

Hey LastPass support team, was there anything changed on your end that is allowing this to work now via conditional access?


My colleague and I decided to try logging in this morning and it works, we did not run into any issues. (Android Devices, have not tried iPhone yet)



Active Contributor

@Kenneth23  still does not work for me or my users and still no word from LastPass.  

Absolutely ridiculous service

GoTo Contributor

Hi All,


I am very sorry that my previous post about a Christmas present didn't come true.

But there will surely be news on that feature very soon.



New Contributor

This is such a simple fix that many other cloud providers have implemented. Let's get two things straight, LastPass engineers are not "hard at work", they are horrendous. They close cases without even attempting to resolve. It's no surprise 2 years later they have not addressed the issue.


To fix the issue, they just have to enable "native browser" authentication. The LastPass app is using it's own browser to do the authentication. That browser does not pass details about the device to conditional access policies. Native browsers on an iOS device such as Safari, and Edge, do. So if you have a Conditional Access policy based on device compliance, LastPass will be blocked. LastPass has to redirect the authentication to the native browser; SIMPLE. They need to do this for GotoAssist as well.

Active Contributor

Fully agree.

I am beyond frustrated by this.  I used to be a big fan of lastpass.  

we spend a lot of money as enterprise with LastPass and I do not see us renewing again