Showing results for 
Search instead for 
Did you mean: 
New Member

Keychain authentication problem on Mac

I have been using Lastpass for some time, and use both Mac, various iOS devices and a Windows laptop as well. Until now all has been smooth sailing.

Since the MacOS High Sierra upgrade every time I open either Firefox or Chrome on my mac I have to give permission for Lastpass to access the keychain. I have checked the relevant keychain item (lpchrome) and it's set to allow access to both. I tried deleting lpchrome and resetting the security. The problem persisted. I tried setting lpchrome to permit any application to access without a password, again no use.

Having to give permission to access keychain before I browse ANY website is irritating. What's worse, if I don't submit my Keychain password I get no internet access through whichever browser I chose until I close it and then reopen it. This problem has persisted for over a week now.

Please resolve this issue so that Lastpass works properly rather than deleting its own permissions EVERY time non-Safari browsers are closed.

New Member

Re: Keychain authentication problem on Mac

I'm having this same issue on High Sierra. Every time I open Safari or Firefox it goes through the same keychain access prompts. I click Always Allow, but it isn't persistent.
New Member

Re: Keychain authentication problem on Mac

I was having a similar problem, but I stumbled onto this post on the web: ... -keychain/

The author's problem was with Chrome, while I was still using Safari. But I decided to try his fix anyway. One of the websites I was having a problem with was listed in the Keychain in the Applications folder, and also in Safari's Preferences Password list. I deleted it from both and now I can log into the website with no problems. Don't know if this will apply to your situations, but it might be worth a try. Good luck.