cancel
Showing results for 
Search instead for 
Did you mean: 
Captain_Morgan
Active Contributor

Re: LastPass Extension 4.107.0 User Interface not working properly

I'm really not interested in a fancy bloated user interface. I'm more interested in knowing and feeling the LastPass developers thoroughly review and test EVERYTHING before it's released. It's obvious this was a major update to the look and functionality of the extension and it's obvious no one tested it's functionality or performed a user review of the customer facing interface before releasing it. I'm not feeling so confident about the people responsible for maintaining the security of my data. It's a whole lot of eggs (almost 600 for me) in one basket. 

 

Captain_Morgan
Active Contributor

Re: LastPass Extension 4.107.0 User Interface not working properly

Awesome! That worked for me. I can now use the previous version (Edge Extension) and it seems to be working.
DrivesLikeJehu
Active Contributor

Re: LastPass Extension 4.107.0 User Interface not working properly

To which "awesome" solution are you referring? I'm an Edge user too and would like to know how you did what you did. Thanks!

preemo
New Contributor

Re: LastPass Extension 4.107.0 User Interface not working properly

Was forced this morning onto the now Chrome browser add-on. It's a piece of junk. bloated, slow, and the worst thing is is does not work. It takes forever to update and Chrome asks to kill the page. It's not workable. This tells me Lastpass have lost the plot. All I need is for them to keep my stuff safe and they failed at that, now their updates are worse than ever.
Captain_Morgan
Active Contributor

Re: LastPass Extension 4.107.0 User Interface not working properly

See the post by Scott775 with a screenshot on page 4

there's more detail but basically he posted "I went to the vault > Advanced Options and then toggled the "Use improved save and fill" on and back off."

It seems to have worked for me.
PetervL
New Contributor

Re: LastPass Extension 4.107.0 User Interface not working properly

It seems that the functionality that I use from the Chrome extension is working again.

Incredible that these bugs were not detected by your QA. I wonder if you have QA...

What puzzles me: bugs fixed but the version of the extension is still 4.107.0. Not only lack of QA but also of version control.

Spidertheminder
Active Contributor

Re: LastPass Extension 4.107.0 User Interface not working properly

Hi, You go to : > Advanced Options and then toggled off the "Use improved save and fill" Option. It works, if youi are a premium member, not so sure about free accounts, but beware it keeps switching itself back!

 

 do wish they would remove this update

DJSt
New Contributor

Re: LastPass Extension 4.107.0 User Interface not working properly

The update worked once I restarted Chrome.

Thank you.

vbmiller
Active Contributor

Re: LastPass Extension 4.107.0 User Interface not working properly

Not only does my extension not work, I can't see any of my passwords in the vault. Nothing is working on my end. Uninstalled/reinstalled, clear cache, reinstall chrome, disable new save/refill feature. So unreliable, this is crazy.

rpspiker
Active Contributor

Re: LastPass Extension 4.107.0 User Interface not working properly

I'm also experiencing these issues with Edge browser extension:

Copy username or password option opens behind the record.

Search from the browser extension seldom works

Edit is now a tedious, multi-step effort that opens the vault (slow) and now copy and paste.  Using LastPass to track account number, or anything in the notes is slow and more steps than before, 

If you make a change in the vault and it is updating, the browser extension stops functioning until the update has finished, however long that takes.

Do we know if LogMeIn/LastPass is even trying to resolve these seven pages of issues?