cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Active Contributor

Can't connect to Hamachi via iOS devices?

Our office has a working Hamachi Gateway network. Works great for our Windows PCs and Macs. But I've been trying to get our iOS devices to connect without any luck. Hoping someone will see what I'm doing wrong here.

 

From the web page,:

 

Add Client

Add Mobile Client (name the client, tick the checkbox for our “Office Network", tap Create

Tap Send iOS button

Tap Save(?) - which doesn't seem to do anything, while Cancel closed window

 

Note: There's also a "Join Network" section which I don't understand. I typically leave it alone, though whenever I try entering the NetworkID and password from the Device Configuration section it just says "Join Error."

 

On iPhone once email is received:

 

Tap on hamachi attachment in email, says Profile Downloaded

Tap Settings, General, Profiles & Management, tap Hamachi Profile

Tap Install, then Install again

Prompts for “Password for the certificate ‘IPSEC CLIENT’”

Enter the password from the client setup page "Device Configuration" section, tap Next, Done

 

Tap VPN slider to attempt a connection

It prompts for VPN Connection dialog:

UserID: already filled in

Password: same password used above from the "Device Configuration" section?

Tap OK

 

Says Connecting

VPN Connection: Negotiation with the VPN server failed

 

Anyone see what I'm doing wrong?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Active Contributor

Re: Can't connect to Hamachi via iOS devices?

I don't know if this has been answered. I think I know what went wrong. At least I know what worked for me.

The list of instructions you typed is *almost* correct. Here is your problem area. (Don't worry, took me at least 8 tries before I figured it out myself. )

>>> try entering the NetworkID and password from the Device Configuration section it just says "Join Error."

 

That's the problem. Here's what to do: Go back to your "My NetWorks". Click on your network and click "edit" on the far right. Get the NW ID. It's a number like 123-456-789. Then go back as you have outlined and put this NW ID in the Join Network [Network ID] area. I also recommend choosing "Include Password in Config File".  Do click [SAVE]. You need that. What that does is add your device to your Hamachi VPN Network. Now click the [Send iOS] button. (You will note that [Save] is below [Send iOS ] is above. Henh? It's ok.

 

Pretty sure this missing NW ID = 123-456-789 is your problem.

 

Let me add a few more things for completeness: On your iOS device there are three steps.

1) Get the email. Download the config File.

2) Settings:General:Profile Click tiny left arrow. See the Hamachi-Profile and

go thru the install steps. There are 3 steps, I think, you keep saying "yes, I want to do this."

3) Settings:General:VPN  Now you will see the Hamachi-VPN profile and you can use the

[Status NotConnected (... ) to slide to connect. It will connect.

 

Then your iOS device will be connected to your Hamachi Network. The profile only has to be loaded once. It can be deleted anytime you want. Connecting the VPN (step 3) has to be done every time you want to use the NW, and when you have turned your phone off for a while.

 

Once again: NetWork ID 123-456-789  is the thing I finally figured out. It is not some name like MyNetworkFoo that you used as an alias for the ID.

 

Hope this helps.

 

Karl Hudnut

khudnut@adkconsultingllc.com

View solution in original post

5 REPLIES 5
Highlighted
New Contributor

Re: Can't connect to Hamachi via iOS devices?

Hi,

 

Have you been able to solve the issue?. I'm seeing the same with my iphone. Thanks!

Highlighted
New Contributor

Re: Can't connect to Hamachi via iOS devices?

I'm having the same problem in my iPad.

Highlighted
New Contributor

Re: Can't connect to Hamachi via iOS devices?

Same issue on my end. I was able to connect with an Android device just fine prior to trying an iOS device.

Highlighted
New Contributor

Re: Can't connect to Hamachi via iOS devices?

Anyone figure this out yet it is really annoying.

Highlighted
Active Contributor

Re: Can't connect to Hamachi via iOS devices?

I don't know if this has been answered. I think I know what went wrong. At least I know what worked for me.

The list of instructions you typed is *almost* correct. Here is your problem area. (Don't worry, took me at least 8 tries before I figured it out myself. )

>>> try entering the NetworkID and password from the Device Configuration section it just says "Join Error."

 

That's the problem. Here's what to do: Go back to your "My NetWorks". Click on your network and click "edit" on the far right. Get the NW ID. It's a number like 123-456-789. Then go back as you have outlined and put this NW ID in the Join Network [Network ID] area. I also recommend choosing "Include Password in Config File".  Do click [SAVE]. You need that. What that does is add your device to your Hamachi VPN Network. Now click the [Send iOS] button. (You will note that [Save] is below [Send iOS ] is above. Henh? It's ok.

 

Pretty sure this missing NW ID = 123-456-789 is your problem.

 

Let me add a few more things for completeness: On your iOS device there are three steps.

1) Get the email. Download the config File.

2) Settings:General:Profile Click tiny left arrow. See the Hamachi-Profile and

go thru the install steps. There are 3 steps, I think, you keep saying "yes, I want to do this."

3) Settings:General:VPN  Now you will see the Hamachi-VPN profile and you can use the

[Status NotConnected (... ) to slide to connect. It will connect.

 

Then your iOS device will be connected to your Hamachi Network. The profile only has to be loaded once. It can be deleted anytime you want. Connecting the VPN (step 3) has to be done every time you want to use the NW, and when you have turned your phone off for a while.

 

Once again: NetWork ID 123-456-789  is the thing I finally figured out. It is not some name like MyNetworkFoo that you used as an alias for the ID.

 

Hope this helps.

 

Karl Hudnut

khudnut@adkconsultingllc.com

View solution in original post