cancel
Showing results for 
Search instead for 
Did you mean: 
Active Contributor

Connection to Hamachi Servers Failing

This morning all computers at one location are failing to to connect to the Hamachi servers.

I suspect a firewall issue but turning all the firewalls off have failed to resolve the problem.

I did a complete re-install of Hamachi on one PC plus tried all the tip/solutions I can find in this KB.

 

Here's the log file from a new re-started Hamachi.

At the bottom it shows it not connecting to the servers. Can anyone point to anything else I can try?

Also, should I be able to ping the likes of hamachi-list.3.logmein-gateway.com over the public internet or only via an established VPN?

 

Thanks

MikeW

 

02/18 10:59:05.747 [3508] win32_main: EngineConfigDir [C:\Windows\ServiceProfiles\LocalService\AppData\Local\LogMeIn Hamachi]
02/18 10:59:05.752 [3296] svc: entering START_PENDING mode ..
02/18 10:59:05.752 [3296] cfg: cannot open [C:\Windows\ServiceProfiles\LocalService\AppData\Local\LogMeIn Hamachi\h2-engine-override.cfg]
02/18 10:59:05.752 [3296] dbg: deploy_id '51B89341-8CBD-48C3-B2F0-A87EBCA2C98A' parse ok
02/18 10:59:05.757 [3296] starting up ..
02/18 10:59:05.757 [3296] sys: version W81-2.2.0.319
02/18 10:59:05.757 [3296] sys: os version 6.3.9600 sp 0.0 suite 0300 product 01, os_str: [W81]
02/18 10:59:05.782 [3296] vpn: IPv6 support is: 3
02/18 10:59:05.787 [3296] ipc: init() ok
02/18 10:59:05.852 [3296] sys: initializing vpn domains, vpn-reinstall = 0 ..
02/18 10:59:05.857 [3296] tap: new tap: Hamachi
02/18 10:59:05.857 [3296] vpn: added [Hamachi] domain (not roaming)
02/18 10:59:05.857 [3296] dbg: setup_vpn_domain [Hamachi]
02/18 10:59:05.857 [3296] dbg: vpn_domain::config - [Hamachi]
02/18 10:59:05.857 [3296] vpn: switched [Hamachi] domain into L3 mode, 0.0.0.0/0.0.0.0
02/18 10:59:05.862 [3296] dbg: enable(Hamachi), locked: 0
02/18 10:59:05.862 [3296] vpn: domain [Hamachi] -> 'VPN_opening'
02/18 10:59:05.862 [3296] vpn: enabling [Hamachi] domain ..
02/18 10:59:05.862 [3296] tap: win32_set_hw_tapdev(Hamachi) ..
02/18 10:59:05.862 [3296] tap: list_netdev_win32() ..
02/18 10:59:05.877 [3296] tap: job [Hamachi, JOB_set_tapdev, 1] start thread ..
02/18 10:59:05.877 [3296] vpn: added [Null] domain (not roaming)
02/18 10:59:05.877 [3296] dbg: setup_vpn_domain [Null]
02/18 10:59:05.882 [3296] dbg: vpn_domain::config - [Null]
02/18 10:59:05.882 [5264] tap: job [Hamachi, JOB_set_tapdev, 1] thread started
02/18 10:59:05.882 [5264] tap: set_tapdev(Hamachi, up) ..
02/18 10:59:05.882 [5264] tap: list_netdev_win32() ..
02/18 10:59:05.882 [3296] lge: init_logon_events
02/18 10:59:05.887 [3296] lge: init win32 poll logon events
02/18 10:59:05.887 [3296] svc: launch_in_session: [Services], session_id: 0
02/18 10:59:05.887 [3296] svc: launch_in_session: 0
02/18 10:59:05.892 [3296] svc: process 'explorer.exe' not found
02/18 10:59:05.892 [3296] svc: launch_in_session: [Console], session_id: 1
02/18 10:59:05.892 [3296] svc: launch_in_session: 1
02/18 10:59:05.897 [5264] tap: device found, status enabled, not running
02/18 10:59:05.897 [5264] tap: already in a requested state
02/18 10:59:05.932 [3296] svc: spawned process in session 1
02/18 10:59:05.937 [3296] svc: ui started, session: 1
02/18 10:59:05.937 [3296] svc: entering RUNNING mode ..
02/18 10:59:05.937 [3296] svc: entered RUNNING mode
02/18 10:59:05.942 [3296] tap: job [Hamachi, JOB_set_tapdev, 1] done, result: success
02/18 10:59:05.942 [3296] vpn: on_set_tapdev(Hamachi, 1) -> ok
02/18 10:59:05.942 [3296] tap: init(), devName [Hamachi]
02/18 10:59:05.942 [3296] tap: list_netdev_win32() ..
02/18 10:59:05.952 [3296] tap: devName Hamachi
02/18 10:59:05.957 [3296] tap:   fileName  : \\.\HamachiTap.A616FD9E-8796-4ED8-BD87-B897CA05BE41
02/18 10:59:05.957 [3296] tap:   mac       : 7a:79:00:00:00:00
02/18 10:59:05.957 [3296] tap:   queueSize : 0
02/18 10:59:05.957 [3296] tap:   linkSpeed : 1410065408
02/18 10:59:05.962 [3296] tap:   linkMtu   : 1514
02/18 10:59:05.962 [3296] tap:   linkState : 0
02/18 10:59:05.962 [3296] tap:   vdhcp     : 0
02/18 10:59:05.962 [3296] tap:   vdhcp.srv : 0.0.0.1
02/18 10:59:05.967 [3296] tap:   vdhcp.cli : 0.0.0.0 / 0.0.0.0
02/18 10:59:05.967 [3296] tap:   vdhcp.sec : 31536000
02/18 10:59:05.967 [3296] vpn: domain [Hamachi] -> 'VPN_up'
02/18 10:59:05.967 [3296] dbg: setup_vpn_domain [Hamachi]
02/18 10:59:05.972 [3296] dbg: vpn_domain::config - [Hamachi]
02/18 10:59:05.972 [3296] vpn: domain [Hamachi] -> 'VPN_setting_up'
02/18 10:59:05.972 [3296] tap: config(0.0.0.0,0.0.0.0)
02/18 10:59:05.972 [3296] tap: GetAdapterIndexByGuid [{A616FD9E-8796-4ED8-BD87-B897CA05BE41}]
02/18 10:59:05.977 [3296] tap: adapter 00000003 [\DEVICE\TCPIP_{BF1F0EC5-5FAD-48C1-BC6F-42308EEB67DB}]
02/18 10:59:05.977 [3296] tap: adapter 00000006 [\DEVICE\TCPIP_{FA541BFA-5A0C-488A-BBEF-7B8CC134D33D}]
02/18 10:59:05.977 [3296] tap: adapter 00000007 [\DEVICE\TCPIP_{622D1FC4-28C3-414A-9DEC-C6133CA3102E}]
02/18 10:59:05.982 [3296] tap: adapter addr 0.0.0.0/0.0.0.0, dhcp yes, want 0.0.0.0/0.0.0.0, [::/0]
02/18 10:59:05.982 [3296] tap: GetAdapterIndexByGuid [{A616FD9E-8796-4ED8-BD87-B897CA05BE41}]
02/18 10:59:05.987 [3296] tap: adapter 00000003 [\DEVICE\TCPIP_{BF1F0EC5-5FAD-48C1-BC6F-42308EEB67DB}]
02/18 10:59:05.987 [3296] tap: adapter 00000006 [\DEVICE\TCPIP_{FA541BFA-5A0C-488A-BBEF-7B8CC134D33D}]
02/18 10:59:05.987 [3296] tap: adapter 00000007 [\DEVICE\TCPIP_{622D1FC4-28C3-414A-9DEC-C6133CA3102E}]
02/18 10:59:05.987 [3296] tap: enabling virtual dhcp server ..
02/18 10:59:05.992 [3296] tap: setDhcp(0, 0.0.0.1, 0.0.0.0/0.0.0.0) = 1, 183
02/18 10:59:05.992 [3296] vpn: tap config done, [ok]
02/18 10:59:05.992 [3296] vpn: domain [Hamachi] -> 'VPN_up'
02/18 10:59:08.285 [3296] ipc: new connection
02/18 10:59:08.285 [3296] ipc: connection from [M_BRABBS_2]
02/18 10:59:08.290 [3296] ipc: user [M_BRABBS_2]
02/18 10:59:08.290 [3296] ipc: d4579c70 add client 1
02/18 10:59:08.295 [3296] ipc: init() ok
02/18 11:00:50.143 [3296] sys: connmgr_go_online, reconnect 0
02/18 11:00:50.178 [3296] ses: on_conn_state(connected, 0x0)
02/18 11:00:50.178 [3296] ses: select conn mode 'dns lb'
02/18 11:00:50.183 [3296] ses: go_offline, keep_tunnels 1, login_on_relaunch 0, actual state 4 ..
02/18 11:00:50.198 [3296] sys: go_online, reconnect 0
02/18 11:00:50.213 [3296] ses: resolving hamachi-dc.logmein-gateway.com ..
02/18 11:00:50.258 [3296] ses: resolving hamachi-list.3.logmein-gateway.com ..
02/18 11:00:50.298 [3296] ses: selected (h-app03-05.hamachi.cc, 5872)
02/18 11:00:50.298 [3296] ses: selected 01 connection type
02/18 11:00:50.308 [3296] ses: resolving h-app03-05.hamachi.cc ..
02/18 11:00:50.378 [3296] ses: error 3, retryable yes
02/18 11:00:50.378 [3296] ses: selected 02 connection type
02/18 11:00:50.388 [3296] ses: resolving h-app03-05.hamachi.cc ..
02/18 11:00:50.453 [3296] ses: error 3, retryable yes
02/18 11:00:50.453 [3296] ses: selected 04 connection type
02/18 11:00:50.453 [3296] ses: proxy is not configured
02/18 11:00:50.453 [3296] ses: exhausted all connectivity options (07)
02/18 11:00:50.468 [3296] ses: go_offline, keep_tunnels 0, login_on_relaunch 0, actual state 1 ..

1 ACCEPTED SOLUTION

Accepted Solutions
Active Contributor

Re: Connection to Hamachi Servers Failing

Update:

The problem seems to have resolved itself without any configurations changes. Only thing I can think is that our ISP (BT in UK) blocked Hamachi's server IP addresses for a while.

 

DNS lookups/pings that were failing now work.

 

I did reboot router early on without any effect at the time.

 

When I tried pinging the likes of hamachi-dc.logmein-gateway.com from various sites (all BT) the lookups/pings failed previously, now they work and the Hamachi's have connected.

 

I suppose it could have been Hamachi servers not servicing new connections (established VPNs did not fail) but I would have thought there would have been a bigger outcry here.

 

Any it seems to be resolved for now.

 

MikeW

View solution in original post

5 REPLIES 5
Iva
New Contributor

Re: Connection to Hamachi Servers Failing

Hi. I am with the same problem
Active Contributor

Re: Connection to Hamachi Servers Failing

Update:

The problem seems to have resolved itself without any configurations changes. Only thing I can think is that our ISP (BT in UK) blocked Hamachi's server IP addresses for a while.

 

DNS lookups/pings that were failing now work.

 

I did reboot router early on without any effect at the time.

 

When I tried pinging the likes of hamachi-dc.logmein-gateway.com from various sites (all BT) the lookups/pings failed previously, now they work and the Hamachi's have connected.

 

I suppose it could have been Hamachi servers not servicing new connections (established VPNs did not fail) but I would have thought there would have been a bigger outcry here.

 

Any it seems to be resolved for now.

 

MikeW

View solution in original post

New Contributor

Re: Connection to Hamachi Servers Failing

 
New Contributor

Re: Connection to Hamachi Servers Failing

Hi MikeW I still cannot connect to hamachi servers

 

New Contributor

Re: Connection to Hamachi Servers Failing