cancel
Showing results for 
Search instead for 
Did you mean: 
New Contributor

Re: Failed to connect to the network adapter. Peer is not accessible via VPN.


cabsandy wrote:

OK

Old topic but hopefully this fix will help everybody out.I tried EVERY fix on this thread, and none worked.None. Best part of a Sunday gone.

I had been playing about with different networks, when I couldn't connect to the new Gateway network I had created, when before, it had been fine. What I had to do was RENAME the virtual adaptor (that Hamachi creates) in the windows Network Connections panel. You need to get this exactly right, otherwise the adaptor wont pick up an ip address from the DHCP server on the LAN the Gateway resides. The name you need to give it is Hamachi - xxx-xxx-xxx where the xxx-xxx-xxx is the network ID you find in the web control panel (or any other client machines connected to said network). So an example would be 

Hamachi - 172-999-666 .Note the space after the i in Hamachi, and again after the hyphen.So again:

 

Hamachi (space)-(space)172-999-666 

 

I hope this helps someone-I have no idea why this would need to be the case (my machine is WIN7 Home) as the two other machines (WINXP and WINXP Pro) connected just fine!!

 

cabs


How do I find the gateway network ID? How do i rename the virtual adapter via Device Manager (Win7)? Thanks.

New Contributor

Create a New Network

Dear Support Team,

 

After installation newer version of Hamachi version 2.2.0038 , I'm not able to create a new network and it's stuge there without any error for Windows 8.1. And I have try turn off the firewall and uninstall Anti-virus but it's still the same cannot create a new network.

 

May I know anyone of you encounter this problem before. Please advise

 

Thank you very much.

 

Chin

New Contributor

Re: Failed to connect to the network adapter. Peer is not accessible via VPN.

 
New Contributor

Re: Failed to connect to the network adapter. Peer is not accessible via VPN.

can you tell me who you read from and solved your issue please?

New Contributor

Re: Failed to connect to the network adapter. Peer is not accessible via VPN.

THANKS ALOT

 

IT REALLY WORKED PROPERLY...AL HAMDULELLAH ...

 

THANKS FOR YOUR KIND HELP AND SUPPORT..

 

Eng. OMAR BEN SALEM

00971506996277

New Contributor

Re: Failed to connect to the network adapter. Peer is not accessible via VPN.

Hi all, My hamachi network suffered from the same problem. Im currently on 8.1 after trying most of the fixes and failed what worked for me was very simple.

 

I have a copy of the latest installation of hamachi so i ran it. and choose the reinstall option. The installer took care of everything from deleting the network driver quiting all the process, then it reinstalled everything while still maintaining all my settings and connections.

New Contributor

Re: Failed to connect to the network adapter. Peer is not accessible via VPN.

Gateway doesn't work on Windows 10. I switched it back to a windows 8.1 box and everything works again. Yes you do have to make sure the network connection is renamed if the new install didn't do it for you.

New Contributor

Re: Failed to connect to the network adapter. Peer is not accessible via VPN.

Worked for me.  I stopped the LMI Hamachi Tunneling Engine, disabled and reanabled the adaptor, started the service and it is working.  Thanks for the tip!

New Contributor

Re: Failed to connect to the network adapter. Peer is not accessible via VPN.

Same problem here as everyone.

Tried every mentioned solution, except adapter renaming because hamachi network adapter doesn't show on my network adapter list, it is listed however in device manager. 

I'm on Windows 7 Ultimate x64 sp1 and got latest hamachi client(2.2.0.410) downloaded from a deployment link.

 Does anybody know other way to rename network adapter?

New Contributor

Re: Failed to connect to the network adapter. Peer is not accessible via VPN.

Hey everyone who's reading this thread and still finding a solution for this, I just recently solved it on my end after 2 days of google searching.

 

1) Uninstall hamachi and remove from program file x86 / network adapter from device manager if it's still there.

2) Remove any other vpn's you have (I did this just in case).

3) GET A DIFFERENT INSTALLER FILE THAT'S NOT FROM HAMACHI GUEST HOMEPAGE.

 

Why? I have no clue, it seems the installer file they have up is borked or something. I got used a different version of the installer, 2.2.0.377.

 

4) Proceed download as usual, then that annoying yellow triangle should be gone. At least it did for me.