cancel
Showing results for 
Search instead for 
Did you mean: 
SELDOMUSED
Active Contributor

Incompatible with macOS Catalina

I've reviewed several threads on this, but can't seem to find the answer. 

 

How do I get GTMPC to work with mac OS Catalina?

 

Thank you.

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
SELDOMUSED
Active Contributor

Re: Incompatible with macOS Catalina

Thanks, AshC.

 

After many attempts at deleting files, only to have it reinstall 2199, they finally came across a solution - instead of "upgrading" to the newest version a tech dialed in to my work computer, uninstalled GTMPC and reinstalled it.  This caused an upgrade to a newer version and it now works.

 

Not sure why, but the deleting of the files above and those identified by the tech before uninstalling, didnt work.  It kept installing 2199.  The thing that solved the issue was upgarding the version.

 

Thanks to all that chimed in.

View solution in original post

18 REPLIES 18
Abhishek Yadav
LogMeIn Contributor

Re: Incompatible with macOS Catalina

It's compatible. Which endpoint build you are on?

SELDOMUSED
Active Contributor

Re: Incompatible with macOS Catalina

I'm not sure, how can I check?  Since the upgrade to Catalina when I try to launch the opener I get an error message (2199) saying to contact the publisher.  Won't let me go past that.

 

Would a screenshot help figure it out? If so, I can do that.

 

Thank you for your help!

SELDOMUSED
Active Contributor

Re: Incompatible with macOS Catalina

This is the message I get when I try to open the launcher.

 

I should say, the computer is on a network at my employer, but prior to Catalina I was able to connect.

 

Thank you.Screen Shot 2020-04-30 at 6.10.58 PM.png

 

SELDOMUSED
Active Contributor

Re: Incompatible with macOS Catalina

Still getting error on Catlain 10.15.4.

 

Can someone assist?

 

Thank you.

Abhishek Yadav
LogMeIn Contributor

Re: Incompatible with macOS Catalina

You aren't on latest build. Try updating G2P host and it will start working.
SELDOMUSED
Active Contributor

Re: Incompatible with macOS Catalina

I'll search on how to update the G2P host, but can your provide a link or instructions?

 

This is through a work account, so can I even update the host or is it something IT would have to do?

 

Sorry for the "stupid" questions. 🙂

Abhishek Yadav
LogMeIn Contributor

Re: Incompatible with macOS Catalina

That's fine 🙂
On your host computer, right click on gtmpc tray icon and click on check for upgrade. If there's an upgrade available then your host app will get upgraded. In case, and if it doesn't happen then contact your IT admin. He will need to allow you to upgrade to latest build.
SELDOMUSED
Active Contributor

Re: Incompatible with macOS Catalina

Thank you, so much for your help.

SELDOMUSED
Active Contributor

Re: Incompatible with macOS Catalina

To follow up, I talked to my IT and actually they say the issue is on my Mac - it's a PList file that the MAC uses for preferences.  Supposedly this file tells the Mac which program to use and if I delete this file and attempt go to gotomypc it should look for the file, not find it and download the latest.

 

To me this makes sense because the problem arises before I ever connect to my work network - i.e. right when I try and log on to gotomypc on my Mac before I ever get connected. 

 

Can anyone confirm? And, what is the name of the file I should delete?

 

Thanks.